Scott R Parish
Posts as srp@srparish.net.
69
messages
35
patches posted
14%
of 7 series merged
22
threads started
2007
first message, Oct 19, 2007
Feb 5, 2008
since the latest message
Patch series
Of 7 patch series (re-rolls counted once), 1 landed on master and 6 did not.
- merged"git" returns 1; "git help" and "git help -a" return 0Oct 29, 2007, 384df83312
- not mergeddon't set-group-id on directories on appleOct 22, 2007
- not merged"git help -a" should search all exec_paths and PATHOct 21, 2007
- not merged"git help" and "git help -a" shouldn't exit(1) unless they errorOct 21, 2007
- not mergedIf git is ran with a relative path, try building an absolute exec_path from itOct 20, 2007
- not mergedWhen exec'ing sub-commands, fall back on execvp (the PATH)Oct 20, 2007
- not mergedallow git to use the PATH for finding subcommands and help docsOct 19, 2007
A series is merged when one of its patches matches a commit on master by the same author, by subject. Versions are linked when they share a patch subject. Patches reworded before landing, or applied under someone else's name, count as not merged.
Recent emails
- Re: git-daemon breakage in 1.5.4
- Re: [PATCH 6/7] include $PATH in generating list of commands for "help -a"
- include $PATH in generating list of commands for "help -a"
- Re: [PATCH 6/7] include $PATH in generating list of commands for "help -a"
- include $PATH in generating list of commands for "help -a"
- Re: [PATCH 6/7] include $PATH in generating list of commands for "help -a"
- include $PATH in generating list of commands for "help -a"
- use only the $PATH for exec'ing git commands
- Re: [PATCH 6/7] walk $PATH to generate list of commands for "help -a"
- Re: [PATCH 6/7] walk $PATH to generate list of commands for "help -a"
- shell should call the new setup_path() to setup $PATH
- walk $PATH to generate list of commands for "help -a"
- use only the $PATH for exec'ing git commands
- list_commands(): simplify code by using chdir()
- "current_exec_path" is a misleading name, use "argv_exec_path"
- remove unused/unneeded "pattern" argument of list_commands
- "git" returns 1; "git help" and "git help -a" return 0
- Re: [PATCH 1/7] "git" calls help_unknown_cmd(""); "git help" and "git help -a" return 0
- Re: [PATCH 6/7] walk PATH to generate list of commands for "help -a"
- chdir() into list_commands() dir instead of building paths for stat()
- remove unused/unneeded "pattern" argument of list_commands
- Re: [PATCH 6/7] walk PATH to generate list of commands for "help -a"
- Re: [PATCH 2/7] s/pattern/prefix/ in help's list_commands
- Re: [PATCH 1/7] "git" calls help_unknown_cmd(""); "git help" and "git help -a" return 0
- shell should call setup_path() instead of manually setting up its path
- shell should call setup_path() instead of manually setting up its path
- walk PATH to generate list of commands for "help -a"
- chdir() into list_commands() dir instead of building paths for stat()
- use only the PATH for exec'ing git commands
- "current_exec_path" is a misleading name, use "argv_exec_path" Signed-off-by: Scott R Parish <srp@srparish.net>