git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 01/10] Add a birdview-on-the-source-code section to the user manual

From
Jeff King <peff@peff.net>
Date
May 15, 2007, 05:08 UTC
Message-ID
<20070515050808.GA11745@coredump.intra.peff.net>
In-Reply-To
<20070515045044.GB2805@fieldses.org>
On Tue, May 15, 2007 at 12:50:44AM -0400, J. Bruce Fields wrote:
Show 25 quoted lines
> But the mail I got through the git list yesterday has some odd stuff in
> it:
> 
> From git-owner@vger.kernel.org Mon May 14 11:22:01 2007
> Received: from vger.kernel.org ([209.132.176.167])
> 	by fieldses.org with esmtp (Exim 4.67)
> 	(envelope-from <git-owner@vger.kernel.org>)
> 	id 1HncN6-00051C-Mh
> 	for bfields@fieldses.org; Mon, 14 May 2007 11:22:01 -0400
> Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand
> 	id S1755729AbXENPVe (ORCPT <rfc822;bfields@fieldses.org>);
> 	Mon, 14 May 2007 11:21:34 -0400
> X-Warning: Original message contained 8-bit characters, however during
> 	   the SMTP transport session the receiving system did not announce
> 	   capability of receiving 8-bit SMTP (RFC 1651-1653), and as this
> 	   message does not have MIME headers (RFC 2045-2049) to enable
> 	   encoding change, we had very little choice.
> X-Warning: We ASSUME it is less harmful to add the MIME headers, and
> 	   convert the text to Quoted-Printable, than not to do so,
> 	   and to strip the message to 7-bits.. (RFC 1428 Appendix A)
> X-Warning: We don't know what character set the user used, thus we had to
> 	   write these MIME-headers with our local system default value.
> MIME-Version: 1.0
> Content-Transfer-Encoding: QUOTED-PRINTABLE
> Content-Type: TEXT/PLAIN; charset=ISO-8859-1

Interesting. vger is correct in translating, since your mail server does _not_ advertise the 8BITMIME extension (even though exim is 8-bit clean, and could handle it).

However, the content-type is already specified, so it shouldn't need to
rewrite. However, I notice that your original message is missing a
MIME-Version: 1.0 header. My guess is that vger's logic is that without
that header, it can't trust the Content-Type you have provided (and
indeed, not including MIME-Version violates the MIME RFCs, I believe).

I assumed this was a bug in git-send-email, but looking closer, it doesn't put in any mime information at all! So your sending smtp server is adding in the content-type header, but it's failing to add the MIME-Version header, which I think is a bug (I can dig up the RFC reference if you want).

Arguably, git should be generating the full MIME header-set, since it knows what actual encoding the message is in.

-Peff
Previous: J. Bruce FieldsNext: Jeffrey C. Ollie
Message 6 of 17 in “Re: [PATCH 01/10] Add a birdview-on-the-source-code section to the user manual”
  1. Karl HasselströmMay 14, 2007
  2. J. Bruce FieldsMay 14, 2007
  3. Matthieu MoyMay 14, 2007
  4. Karl HasselströmMay 14, 2007
  5. J. Bruce FieldsMay 15, 2007
  6. Jeff KingMay 15, 2007
  7. Jeffrey C. OllieMay 15, 2007
  8. Jeff KingMay 15, 2007
  9. Karl HasselströmMay 15, 2007
  10. Junio C HamanoMay 15, 2007
  11. Jeff KingMay 15, 2007
  12. Junio C HamanoMay 15, 2007
  13. Jeff KingMay 16, 2007
  14. J. Bruce FieldsMay 15, 2007
  15. Jeff KingMay 15, 2007
  16. Junio C HamanoMay 15, 2007
  17. Jeff KingMay 16, 2007

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.