Re: git-fast-import
- From
Shawn O. Pearce <spearce@spearce.org>
- Date
- Feb 6, 2007, 21:15 UTC
- Message-ID
- <20070206211547.GB5820@spearce.org>
- In-Reply-To
- <Pine.LNX.4.64.0702061559160.13009@xanadu.home>
Nicolas Pitre <nico@cam.org> wrote:
> I think you should call it something else than rfc2822. Because > parse_date() accepts much more than just rfc2822. What about "cooked"?
It does accept a lot more than that, but straying away from rfc2822 gets into the grey areas of parse_date(). E.g. it matches crap such as 'yyyy-mm-dd' or 'yyyy-dd-mm'. But that is completely ambiguous!
I don't really want to advertise that it is accepting non-RFC 2822 input here. I was thinking of doing an `iso` (yyyy-mm-dd hh:mm:ss) format, which may just defer into parse_date(), but again encourage the frontend to *only* feed that ISO style format.
-- Shawn.