From: Etienne Buira Date: Mon, 13 Oct 2014 15:19:11 GMT Subject: Re: [PATCH v2] Handle atexit list internaly for unthreaded builds Message-ID: <1413213552-13769-1-git-send-email-etienne.buira@gmail.com> In-Reply-To: On Mon, Oct 13, 2014 at 2:56 AM, Duy Nguyen wrote: > On Sun, Oct 12, 2014 at 4:09 PM, Etienne Buira wrote: > > Replace atexit()s calls with cmd_atexit that is atexit() on threaded > > builds, but handles the callbacks list internally for unthreaded builds. > > Maybe hide this in git-compat-util.h and "#define atexit(x) > cmd_atexit(x)"? Updated. > cmd_ is usually for commands' "main" functions. Maybe > rename it to git_atexit(). Indeed, renamed. Thank you.