git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 1/3][GSOC] diff: rename read_directory() to get_directory_list()

From
Hiroyuki Sano <sh19910711@gmail.com>
Date
Mar 17, 2014, 21:30 UTC
Message-ID
<1395091825-8330-1-git-send-email-sh19910711@gmail.com>

Including "dir.h" in "diff-no-index.c", it causes a compile error, because the same name function read_directory() is declared globally in "dir.h".

This change is to avoid conflicts as above.
Signed-off-by: Hiroyuki Sano <sh19910711@gmail.com>
---
 diff-no-index.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/diff-no-index.c b/diff-no-index.c
index 8e10bff..1ed5c9d 100644
--- a/diff-no-index.c
+++ b/diff-no-index.c
@@ -16,7 +16,7 @@
 #include "builtin.h"
 #include "string-list.h"
 
-static int read_directory(const char *path, struct string_list *list)
+static int get_directory_list(const char *path, struct string_list *list)
 {
 	DIR *dir;
 	struct dirent *e;
@@ -107,9 +107,9 @@ static int queue_diff(struct diff_options *o,
 		int i1, i2, ret = 0;
 		size_t len1 = 0, len2 = 0;
 
-		if (name1 && read_directory(name1, &p1))
+		if (name1 && get_directory_list(name1, &p1))
 			return -1;
-		if (name2 && read_directory(name2, &p2)) {
+		if (name2 && get_directory_list(name2, &p2)) {
 			string_list_clear(&p1, 0);
 			return -1;
 		}
-- 
1.9.0
Next: Hiroyuki Sano
Message 1 of 8 in “[GSOC] diff: rename read_directory() to get_directory_list()”
  1. 1/3 [GSOC] diff: rename read_directory() to get_directory_list()Hiroyuki Sano, Mar 17, 2014
  2. 2/3 [GSOC] diff: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 17, 2014
  3. 3/3 [GSOC] fsck: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 17, 2014
  4. Junio C HamanoMar 17, 2014
  5. Junio C HamanoMar 17, 2014
  6. Junio C HamanoMar 19, 2014
  7. Junio C HamanoMar 19, 2014
  8. Eric SunshineMar 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.