git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/3][GSOC] diff: rename read_directory() to get_directory_list()

From
Junio C Hamano <gitster@pobox.com>
Date
Mar 19, 2014, 18:48 UTC
Message-ID
<xmqq1txy3tyk.fsf@gitster.dls.corp.google.com>
In-Reply-To
<xmqq4n2u5cif.fsf@gitster.dls.corp.google.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 13 quoted lines
>>> -static int read_directory(const char *path, struct string_list *list)
>>> +static int get_directory_list(const char *path, struct string_list *list)
>>
>> Renaming is a good idea but the new name sounds like you are
>> grabbing the names of directories, ignoring all the files, no?
>
> I am tempted to suggest, because this is an internal implementation
> detail only visible to this narrow corner of the system, calling
> this just 
>
> 	static int ls(const char *path, struct string_list *result)
>
> ;-)
Scratch that one.

I'll take read_directory_contents() from Brian Bourn, which essentially is the same patch.

Thanks.
-- >8 --
From: Brian Bourn <ba.bourn@gmail.com>
Date: Wed, 19 Mar 2014 11:58:21 -0400
Subject: [PATCH] diff-no-index: rename read_directory()

In the next patch, we will replace a manual checking of "." or ".." with a call to is_dot_or_dotdot() defined in dir.h. The private function read_directory() defined in this file will conflict with the global function declared there when we do so.

As a preparatory step, rename the private read_directory() to avoid the name collision.

Signed-off-by: Brian Bourn <ba.bourn@gmail.com>
Helped-by: Eric Sunshine <sunshine@sunshineco.com>
Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 diff-no-index.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/diff-no-index.c b/diff-no-index.c
index 33e5982..3e4f47e 100644
--- a/diff-no-index.c
+++ b/diff-no-index.c
@@ -16,7 +16,7 @@
 #include "builtin.h"
 #include "string-list.h"
 
-static int read_directory(const char *path, struct string_list *list)
+static int read_directory_contents(const char *path, struct string_list *list)
 {
 	DIR *dir;
 	struct dirent *e;
@@ -107,9 +107,9 @@ static int queue_diff(struct diff_options *o,
 		int i1, i2, ret = 0;
 		size_t len1 = 0, len2 = 0;
 
-		if (name1 && read_directory(name1, &p1))
+		if (name1 && read_directory_contents(name1, &p1))
 			return -1;
-		if (name2 && read_directory(name2, &p2)) {
+		if (name2 && read_directory_contents(name2, &p2)) {
 			string_list_clear(&p1, 0);
 			return -1;
 		}
-- 
1.9.1-423-g4596e3a
Previous: Junio C HamanoNext: Eric Sunshine
Message 7 of 8 in “[GSOC] diff: rename read_directory() to get_directory_list()”
  1. 1/3 [GSOC] diff: rename read_directory() to get_directory_list()Hiroyuki Sano, Mar 17, 2014
  2. 2/3 [GSOC] diff: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 17, 2014
  3. 3/3 [GSOC] fsck: use is_dot_or_dotdot() instead of strcmp()Hiroyuki Sano, Mar 17, 2014
  4. Junio C HamanoMar 17, 2014
  5. Junio C HamanoMar 17, 2014
  6. Junio C HamanoMar 19, 2014
  7. Junio C HamanoMar 19, 2014
  8. Eric SunshineMar 19, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.