git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 08/18] revert: Separate cmdline parsing from functional code

From
Ramkumar Ramachandra <artagnon@gmail.com>
Date
Aug 4, 2011, 10:39 UTC
Message-ID
<1312454356-3070-9-git-send-email-artagnon@gmail.com>
In-Reply-To
<1312454356-3070-1-git-send-email-artagnon@gmail.com>

Currently, revert_or_cherry_pick sets up a default git config, parses command-line arguments, before preparing to pick commits. This makes for a bad API as the central worry of callers is to assert whether or not a conflict occured while cherry picking. The current API is like:

  if (revert_or_cherry_pick(argc, argv, opts) < 0)
     print "Something failed, we're not sure what"

Simplify and rename revert_or_cherry_pick to pick_commits so that it only has the responsibility of setting up the revision walker and picking commits in a loop. Transfer the remaining work to its callers. Now, the API is simplified as:

  if (parse_args(argc, argv, opts) < 0)
     print "Can't parse arguments"
  if (pick_commits(opts) < 0)
     print "Error encountered in picking machinery"

Later in the series, pick_commits will also serve as the starting point for continuing a cherry-pick or revert.

Inspired-by: Christian Couder <chriscool@tuxfamily.org>
Helped-by: Jonathan Nieder <jrnieder@gmail.com>
Signed-off-by: Ramkumar Ramachandra <artagnon@gmail.com>
Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
---
 builtin/revert.c |   14 +++++++-------
 1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/builtin/revert.c b/builtin/revert.c
index 50f72de..90fe2ef 100644
--- a/builtin/revert.c
+++ b/builtin/revert.c
@@ -563,16 +563,12 @@ static void read_and_refresh_cache(struct replay_opts *opts)
 	rollback_lock_file(&index_lock);
 }
 
-static int revert_or_cherry_pick(int argc, const char **argv,
-				struct replay_opts *opts)
+static int pick_commits(struct replay_opts *opts)
 {
 	struct rev_info revs;
 	struct commit *commit;
 
-	git_config(git_default_config, NULL);
 	setenv(GIT_REFLOG_ACTION, action_name(opts), 0);
-	parse_args(argc, argv, opts);
-
 	if (opts->allow_ff) {
 		if (opts->signoff)
 			die(_("cherry-pick --ff cannot be used with --signoff"));
@@ -605,7 +601,9 @@ int cmd_revert(int argc, const char **argv, const char *prefix)
 	if (isatty(0))
 		opts.edit = 1;
 	opts.action = REVERT;
-	return revert_or_cherry_pick(argc, argv, &opts);
+	git_config(git_default_config, NULL);
+	parse_args(argc, argv, &opts);
+	return pick_commits(&opts);
 }
 
 int cmd_cherry_pick(int argc, const char **argv, const char *prefix)
@@ -614,5 +612,7 @@ int cmd_cherry_pick(int argc, const char **argv, const char *prefix)
 
 	memset(&opts, 0, sizeof(opts));
 	opts.action = CHERRY_PICK;
-	return revert_or_cherry_pick(argc, argv, &opts);
+	git_config(git_default_config, NULL);
+	parse_args(argc, argv, &opts);
+	return pick_commits(&opts);
 }
-- 
1.7.6.351.gb35ac.dirty
Previous: Ramkumar RamachandraNext: Ramkumar Ramachandra
Message 9 of 25 in “Sequencer for inclusion v6”
  1. 00/18 Sequencer for inclusion v6Ramkumar Ramachandra, Aug 4, 2011
  2. 01/18 advice: Introduce error_resolve_conflictRamkumar Ramachandra, Aug 4, 2011
  3. 02/18 config: Introduce functions to write non-standard fileRamkumar Ramachandra, Aug 4, 2011
  4. 03/18 revert: Simplify and inline add_message_to_msgRamkumar Ramachandra, Aug 4, 2011
  5. 04/18 revert: Don't check lone argument in get_encodingRamkumar Ramachandra, Aug 4, 2011
  6. 05/18 revert: Rename no_replay to record_originRamkumar Ramachandra, Aug 4, 2011
  7. 06/18 revert: Eliminate global "commit" variableRamkumar Ramachandra, Aug 4, 2011
  8. 07/18 revert: Introduce struct to keep command-line optionsRamkumar Ramachandra, Aug 4, 2011
  9. 08/18 revert: Separate cmdline parsing from functional codeRamkumar Ramachandra, Aug 4, 2011
  10. 09/18 revert: Don't create invalid replay_opts in parse_argsRamkumar Ramachandra, Aug 4, 2011
  11. 10/18 revert: Save data for continuing after conflict resolutionRamkumar Ramachandra, Aug 4, 2011
  12. 11/18 revert: Save command-line options for continuing operationRamkumar Ramachandra, Aug 4, 2011
  13. 12/18 revert: Make pick_commits functionally act on a commit listRamkumar Ramachandra, Aug 4, 2011
  14. 13/18 revert: Introduce --reset to remove sequencer stateRamkumar Ramachandra, Aug 4, 2011
  15. 14/18 reset: Make reset remove the sequencer stateRamkumar Ramachandra, Aug 4, 2011
  16. Christian CouderAug 8, 2011
  17. Ramkumar RamachandraAug 8, 2011
  18. 15/18 revert: Remove sequencer state when no commits are pendingRamkumar Ramachandra, Aug 4, 2011
  19. 16/18 revert: Don't implicitly stomp pending sequencer operationRamkumar Ramachandra, Aug 4, 2011
  20. 17/18 revert: Introduce --continue to continue the operationRamkumar Ramachandra, Aug 4, 2011
  21. Christian CouderAug 8, 2011
  22. Ramkumar RamachandraAug 8, 2011
  23. Junio C HamanoAug 8, 2011
  24. Ramkumar RamachandraAug 9, 2011
  25. 18/18 revert: Propagate errors upwards from do_pick_commitRamkumar Ramachandra, Aug 4, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.