git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 00/18] Sequencer for inclusion v6

From
Ramkumar Ramachandra <artagnon@gmail.com>
Date
Aug 4, 2011, 10:38 UTC
Message-ID
<1312454356-3070-1-git-send-email-artagnon@gmail.com>
Hi,
Apart from the minor style changes, there are two big hilights in this
iteration of the series:
1. The "--continue complains when there are unresolved conflicts" test
is fixed.  I'd written "base..picked" instead of "base..anotherpick"
earlier.
2. Special handling for the last line in the instruction sheet (when
it is not terminated by a newline).  See [1] for an especially
convincing explanation from Junio.

All the changes made in this iteration are a direct result of Christian's reviews -- a big thanks.

Thanks for reading.
-- Ram
[1]: http://mid.gmane.org/7v4o1ycsi4.fsf@alter.siamese.dyndns.org
Ramkumar Ramachandra (18):
  advice: Introduce error_resolve_conflict
  config: Introduce functions to write non-standard file
  revert: Simplify and inline add_message_to_msg
  revert: Don't check lone argument in get_encoding
  revert: Rename no_replay to record_origin
  revert: Eliminate global "commit" variable
  revert: Introduce struct to keep command-line options
  revert: Separate cmdline parsing from functional code
  revert: Don't create invalid replay_opts in parse_args
  revert: Save data for continuing after conflict resolution
  revert: Save command-line options for continuing operation
  revert: Make pick_commits functionally act on a commit list
  revert: Introduce --reset to remove sequencer state
  reset: Make reset remove the sequencer state
  revert: Remove sequencer state when no commits are pending
  revert: Don't implicitly stomp pending sequencer operation
  revert: Introduce --continue to continue the operation
  revert: Propagate errors upwards from do_pick_commit
 Documentation/git-cherry-pick.txt |    6 +
 Documentation/git-revert.txt      |    6 +
 Documentation/sequencer.txt       |    9 +
 Makefile                          |    2 +
 advice.c                          |   31 ++-
 advice.h                          |    3 +-
 branch.c                          |    2 +
 builtin/revert.c                  |  737 +++++++++++++++++++++++++++++--------
 cache.h                           |    2 +
 config.c                          |   36 ++-
 sequencer.c                       |   19 +
 sequencer.h                       |   20 +
 t/7106-reset-sequence.sh          |   44 +++
 t/t3510-cherry-pick-sequence.sh   |  214 +++++++++++
 14 files changed, 960 insertions(+), 171 deletions(-)
 create mode 100644 Documentation/sequencer.txt
 create mode 100644 sequencer.c
 create mode 100644 sequencer.h
 create mode 100755 t/7106-reset-sequence.sh
 create mode 100755 t/t3510-cherry-pick-sequence.sh
-- 
1.7.6.351.gb35ac.dirty
Next: Ramkumar Ramachandra
Message 1 of 25 in “Sequencer for inclusion v6”
  1. 00/18 Sequencer for inclusion v6Ramkumar Ramachandra, Aug 4, 2011
  2. 01/18 advice: Introduce error_resolve_conflictRamkumar Ramachandra, Aug 4, 2011
  3. 02/18 config: Introduce functions to write non-standard fileRamkumar Ramachandra, Aug 4, 2011
  4. 03/18 revert: Simplify and inline add_message_to_msgRamkumar Ramachandra, Aug 4, 2011
  5. 04/18 revert: Don't check lone argument in get_encodingRamkumar Ramachandra, Aug 4, 2011
  6. 05/18 revert: Rename no_replay to record_originRamkumar Ramachandra, Aug 4, 2011
  7. 06/18 revert: Eliminate global "commit" variableRamkumar Ramachandra, Aug 4, 2011
  8. 07/18 revert: Introduce struct to keep command-line optionsRamkumar Ramachandra, Aug 4, 2011
  9. 08/18 revert: Separate cmdline parsing from functional codeRamkumar Ramachandra, Aug 4, 2011
  10. 09/18 revert: Don't create invalid replay_opts in parse_argsRamkumar Ramachandra, Aug 4, 2011
  11. 10/18 revert: Save data for continuing after conflict resolutionRamkumar Ramachandra, Aug 4, 2011
  12. 11/18 revert: Save command-line options for continuing operationRamkumar Ramachandra, Aug 4, 2011
  13. 12/18 revert: Make pick_commits functionally act on a commit listRamkumar Ramachandra, Aug 4, 2011
  14. 13/18 revert: Introduce --reset to remove sequencer stateRamkumar Ramachandra, Aug 4, 2011
  15. 14/18 reset: Make reset remove the sequencer stateRamkumar Ramachandra, Aug 4, 2011
  16. Christian CouderAug 8, 2011
  17. Ramkumar RamachandraAug 8, 2011
  18. 15/18 revert: Remove sequencer state when no commits are pendingRamkumar Ramachandra, Aug 4, 2011
  19. 16/18 revert: Don't implicitly stomp pending sequencer operationRamkumar Ramachandra, Aug 4, 2011
  20. 17/18 revert: Introduce --continue to continue the operationRamkumar Ramachandra, Aug 4, 2011
  21. Christian CouderAug 8, 2011
  22. Ramkumar RamachandraAug 8, 2011
  23. Junio C HamanoAug 8, 2011
  24. Ramkumar RamachandraAug 9, 2011
  25. 18/18 revert: Propagate errors upwards from do_pick_commitRamkumar Ramachandra, Aug 4, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.