[PATCH 3/3] git-instaweb: Don't assume Apache executable is named apache2
- From
Dan McGee <dpmcgee@gmail.com>
- Date
- Jun 30, 2010, 12:29 UTC
- Message-ID
- <1277900948-16375-1-git-send-email-dpmcgee@gmail.com>
- In-Reply-To
- <20100630073153.GA25218@dcvr.yhbt.net>
On Arch Linux, we keep the original 'httpd' name for the exectuable and don't rename it or the path to the modules. Remove some of these assumptions and add the httpd name in where it may be required. Finally, make some slight style adjustments to the code we are touching to make it fit the style of the rest of the script.
Signed-off-by: Dan McGee <dpmcgee@gmail.com> ---
Style cleanups as suggested by Eric, at least to the parts of the code I touched.
-Dan
git-instaweb.sh | 19 ++++++++++++++----- 1 files changed, 14 insertions(+), 5 deletions(-)
diff --git a/git-instaweb.sh b/git-instaweb.sh index 1d349b8..b7342e2 100755 --- a/git-instaweb.sh +++ b/git-instaweb.sh @@ -43,7 +43,8 @@ test -z "$port" && port=1234 resolve_full_httpd () { case "$httpd" in - *apache2*|*lighttpd*) + *apache2*|*lighttpd*|*httpd*) + # yes, *httpd* covers *lighttpd* above, but it is there for clarity # ensure that the apache2/lighttpd command ends with "-f" if ! echo "$httpd" | sane_grep -- '-f *$' >/dev/null 2>&1 then @@ -300,7 +301,13 @@ EOF } apache2_conf () { - test -z "$module_path" && module_path=/usr/lib/apache2/modules + if test -z "$module_path" + then + test -d "/usr/lib/httpd/modules" && + module_path="/usr/lib/httpd/modules" + test -d "/usr/lib/apache2/modules" && + module_path="/usr/lib/apache2/modules" + fi bind= test x"$local" = xtrue && bind='127.0.0.1:' echo 'text/css css' > "$fqgitdir/mime.types" @@ -314,8 +321,10 @@ PidFile "$fqgitdir/pid" Listen $bind$port EOF - for mod in mime dir env log_config; do - if test -e $module_path/mod_${mod}.so; then + for mod in mime dir env log_config + do + if test -e $module_path/mod_${mod}.so + then echo "LoadModule ${mod}_module " \ "$module_path/mod_${mod}.so" >> "$conf" fi @@ -563,7 +572,7 @@ case "$httpd" in *lighttpd*) lighttpd_conf ;; -*apache2*) +*apache2*|*httpd*) apache2_conf ;; webrick)
-- 1.7.1