git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 4/4] config: avoid calling `labs()` on too-large data type

From
René Scharfe <l.s.r@web.de>
Date
Jun 22, 2019, 10:03 UTC
Message-ID
<0dd77efa-a8f5-9f3c-6057-d6fddfc23563@web.de>
In-Reply-To
<nycvar.QRO.7.76.6.1906212024010.44@tvgsbejvaqbjf.bet>
Am 21.06.19 um 20:35 schrieb Johannes Schindelin:
Show 24 quoted lines
> Hi René,
>
> On Thu, 20 Jun 2019, René Scharfe wrote:
>
>> Subject: [PATCH] config: simplify unit suffix handling
>>
>> parse_unit_factor() checks if a K, M or G is present after a number and
>> multiplies it by 2^10, 2^20 or 2^30, respectively.  One of its callers
>> checks if the result is smaller than the number alone to detect
>> overflows.  The other one passes 1 as the number and does multiplication
>> and overflow check itself in a similar manner.
>>
>> This works, but is inconsistent, and it would break if we added support
>> for a bigger unit factor.  E.g. 16777217T expands to 2^64 + 2^40, which
>> is too big for a 64-bit number.  Modulo 2^64 we get 2^40 == 1TB, which
>> is bigger than the raw number 16777217 == 2^24 + 1, so the overflow
>> would go undetected by that method.
>>
>> Move the multiplication out of parse_unit_factor() and rename it to
>> get_unit_factor() to signify its reduced functionality.  This partially
>
> I do not necessarily think that the name `get_unit_factor()` is better,
> given that we still parse the unit factor. I'd vote for keeping the
> original name.
get_unit_factor() is the original name from before c8deb5a146.
> However, what _does_ make sense is to change that function to _really_
> only parse the unit factor. That is, I would keep the exact signature, I
> just would not multiply `*val` by the unit factor, I would overwrite it by
> the unit factor instead.

So the patch is too big. Its narrative of "let's restore the original code, but keep the good features added since" is not carrying the weight of its many changes.

> At least that is what I would have expected, reading the name
> `parse_unit_factor()`.
Hence the renaming. :)

When I read parse_unit_factor() without any context then I expect it to work in the middle of a string, telling the caller how many characters were recognized. It would then be usable with different units, e.g. for "17KB" just as well as for "100Mbps".

We don't need such a generic function here, of course.
Show 5 quoted lines
>> reverts c8deb5a146 ("Improve error messages when int/long cannot be
>> parsed from config", 2007-12-25), but keeps the improved error messages.
>> Use a return value of 0 to signal an invalid suffix.
>
> This comment should probably become a code comment above the function.

You mean just the last sentence, right? For an exported function I'd agree, but for this short helper I'm not so sure and would rather not bother the reader with easily inferable facts.

>> Signed-off-by: Rene Scharfe <l.s.r@web.de>
>
> What, no accent?

I prefer a recognizable simplified version to a butchered one. Perhaps the world is ready for Unicode now? I still get weirdly transformed characters on letters and parcels, so I'm cautious. Testing the waters with the sender name setting in my MUA for some time now..

Show 13 quoted lines
>> diff --git a/config.c b/config.c
>> index 01c6e9df23..61a8bbb5cd 100644
>> --- a/config.c
>> +++ b/config.c
>> @@ -834,51 +834,46 @@ static int git_parse_source(config_fn_t fn, void *data,
>>  	return error_return;
>>  }
>>
>> -static int parse_unit_factor(const char *end, uintmax_t *val)
>> +static uintmax_t get_unit_factor(const char *end)
>
> It has been a historical wart that the parameter was called `end`. Maybe
> that could be fixed, "while at it"?

I was tempted to do that, and am a bit proud of having resisted that one. I try to avoid "what at it" these days -- if it's worth doing that other thing then it can live in its own patch.

But the name "end" is arguably good, as it signifies that the function only works with unit factors at the end of strings.

Show 23 quoted lines
>>
>>  		errno = 0;
>>  		val = strtoumax(value, &end, 0);
>>  		if (errno == ERANGE)
>>  			return 0;
>> -		oldval = val;
>> -		if (!parse_unit_factor(end, &val)) {
>> +		factor = get_unit_factor(end);
>> +		if (!factor) {
>
> Again, here I would strongly suggest the less intrusive change (with a
> more intuitive outcome):
>
> -		oldval = val;
> -		if (!parse_unit_factor(end, &val)) {
> +		if (!parse_unit_factor(end, &factor)) {
>
>>  			errno = EINVAL;
>>  			return 0;
>>  		}
>> -		if (val > max || oldval > val) {
>> +		if (unsigned_mult_overflows(factor, val) ||
>> +		    factor * val > max) {
I'll split that out, then we can discuss it separately.
René
Previous: Johannes SchindelinNext: René Scharfe
Message 11 of 90 in “Support building with GCC v8.x/v9.x”
  1. 0/4 Support building with GCC v8.x/v9.xJohannes Schindelin via GitGitGadget, Jun 13, 2019
  2. 4/4 config: avoid calling `labs()` on too-large data typeJohannes Schindelin via GitGitGadget, Jun 13, 2019
  3. Junio C HamanoJun 13, 2019
  4. René ScharfeJun 16, 2019
  5. René ScharfeJun 16, 2019
  6. René ScharfeJun 16, 2019
  7. Junio C HamanoJun 16, 2019
  8. René ScharfeJun 20, 2019
  9. Junio C HamanoJun 20, 2019
  10. Johannes SchindelinJun 21, 2019
  11. René ScharfeJun 22, 2019
  12. 1/3 config: use unsigned_mult_overflows to check for overflowsRené Scharfe, Jun 22, 2019
  13. 2/3 config: don't multiply in parse_unit_factor()René Scharfe, Jun 22, 2019
  14. 3/3 config: simplify parsing of unit factorsRené Scharfe, Jun 22, 2019
  15. 3/4 winansi: simplify loading the GetCurrentConsoleFontEx() functionJohannes Schindelin via GitGitGadget, Jun 13, 2019
  16. 1/4 poll (mingw): allow compiling with GCC 8 and DEVELOPER=1Johannes Schindelin via GitGitGadget, Jun 13, 2019
  17. 2/4 kwset: allow building with GCC 8Johannes Schindelin via GitGitGadget, Jun 13, 2019
  18. Junio C HamanoJun 13, 2019
  19. SZEDER GáborJun 14, 2019
  20. 0/4 compat/obstack: update from upstreamSZEDER Gábor, Jun 14, 2019
  21. 2/4 SQUASH??? compat/obstack: fix portability issuesSZEDER Gábor, Jun 14, 2019
  22. 4/4 compat/obstack: fix some sparse warningsSZEDER Gábor, Jun 14, 2019
  23. 3/4 SQUASH??? compat/obstack: fix build errors with ClangSZEDER Gábor, Jun 14, 2019
  24. 1/4 compat/obstack: update from upstreamSZEDER Gábor, Jun 14, 2019
  25. Jeff KingJun 14, 2019
  26. Junio C HamanoJun 14, 2019
  27. Ramsay JonesJun 14, 2019
  28. Ramsay JonesJun 14, 2019
  29. SZEDER GáborJun 17, 2019
  30. Junio C HamanoJun 14, 2019
  31. SZEDER GáborJun 17, 2019
  32. Ævar Arnfjörð BjarmasonJun 14, 2019
  33. Can we just get rid of kwset & obstack in favor of optimistically using PCRE v2 JIT?Ævar Arnfjörð Bjarmason, Jun 14, 2019
  34. Ævar Arnfjörð BjarmasonJun 14, 2019
  35. Jeff KingJun 20, 2019
  36. Carlo ArenasJun 15, 2019
  37. brian m. carlsonJun 15, 2019
  38. Ævar Arnfjörð BjarmasonJun 15, 2019
  39. 0/7 grep: move from kwset to optional PCRE v2Ævar Arnfjörð Bjarmason, Jun 26, 2019
  40. Johannes SchindelinJun 26, 2019
  41. Johannes SchindelinJun 27, 2019
  42. Ævar Arnfjörð BjarmasonJun 27, 2019
  43. Johannes SchindelinJun 27, 2019
  44. 1/9 log tests: test regex backends in "--encode=<enc>" testsÆvar Arnfjörð Bjarmason, Jun 27, 2019
  45. 0/9 grep: move from kwset to optional PCRE v2Ævar Arnfjörð Bjarmason, Jun 27, 2019
  46. Ævar Arnfjörð BjarmasonJun 28, 2019
  47. Junio C HamanoJun 28, 2019
  48. 00/10 grep: move from kwset to optional PCRE v2Ævar Arnfjörð Bjarmason, Jul 1, 2019
  49. Junio C HamanoJul 1, 2019
  50. Ævar Arnfjörð BjarmasonJul 2, 2019
  51. Johannes SchindelinJul 2, 2019
  52. Junio C HamanoJul 2, 2019
  53. Johannes SchindelinJul 3, 2019
  54. Johannes SchindelinJul 3, 2019
  55. Johannes SchindelinJul 3, 2019
  56. 01/10 log tests: test regex backends in "--encode=<enc>" testsÆvar Arnfjörð Bjarmason, Jul 1, 2019
  57. 02/10 grep: don't use PCRE2?_UTF8 with "log --encoding=<non-utf8>"Ævar Arnfjörð Bjarmason, Jul 1, 2019
  58. 03/10 t4210: skip more command-line encoding tests on MinGWÆvar Arnfjörð Bjarmason, Jul 1, 2019
  59. 04/10 grep: inline the return value of a function call used only onceÆvar Arnfjörð Bjarmason, Jul 1, 2019
  60. 05/10 grep tests: move "grep binary" alongside the restÆvar Arnfjörð Bjarmason, Jul 1, 2019
  61. 08/10 grep: drop support for \0 in --fixed-strings <pattern>Ævar Arnfjörð Bjarmason, Jul 1, 2019
  62. 07/10 grep: make the behavior for NUL-byte in patterns saneÆvar Arnfjörð Bjarmason, Jul 1, 2019
  63. 06/10 grep tests: move binary pattern tests into their own fileÆvar Arnfjörð Bjarmason, Jul 1, 2019
  64. 09/10 grep: remove the kwset optimizationÆvar Arnfjörð Bjarmason, Jul 1, 2019
  65. 10/10 grep: use PCRE v2 for optimized fixed-string searchÆvar Arnfjörð Bjarmason, Jul 1, 2019
  66. 2/9 grep: don't use PCRE2?_UTF8 with "log --encoding=<non-utf8>"Ævar Arnfjörð Bjarmason, Jun 27, 2019
  67. 3/9 grep: inline the return value of a function call used only onceÆvar Arnfjörð Bjarmason, Jun 27, 2019
  68. 4/9 grep tests: move "grep binary" alongside the restÆvar Arnfjörð Bjarmason, Jun 27, 2019
  69. 5/9 grep tests: move binary pattern tests into their own fileÆvar Arnfjörð Bjarmason, Jun 27, 2019
  70. 6/9 grep: make the behavior for NUL-byte in patterns saneÆvar Arnfjörð Bjarmason, Jun 27, 2019
  71. 7/9 grep: drop support for \0 in --fixed-strings <pattern>Ævar Arnfjörð Bjarmason, Jun 27, 2019
  72. 8/9 grep: remove the kwset optimizationÆvar Arnfjörð Bjarmason, Jun 27, 2019
  73. 9/9 grep: use PCRE v2 for optimized fixed-string searchÆvar Arnfjörð Bjarmason, Jun 27, 2019
  74. 1/7 grep: inline the return value of a function call used only onceÆvar Arnfjörð Bjarmason, Jun 26, 2019
  75. 2/7 grep tests: move "grep binary" alongside the restÆvar Arnfjörð Bjarmason, Jun 26, 2019
  76. Johannes SchindelinJun 26, 2019
  77. Junio C HamanoJun 26, 2019
  78. 4/7 grep: make the behavior for \0 in patterns saneÆvar Arnfjörð Bjarmason, Jun 26, 2019
  79. brian m. carlsonJun 27, 2019
  80. 3/7 grep tests: move binary pattern tests into their own fileÆvar Arnfjörð Bjarmason, Jun 26, 2019
  81. 5/7 grep: drop support for \0 in --fixed-strings <pattern>Ævar Arnfjörð Bjarmason, Jun 26, 2019
  82. Junio C HamanoJun 26, 2019
  83. 6/7 grep: remove the kwset optimizationÆvar Arnfjörð Bjarmason, Jun 26, 2019
  84. 7/7 grep: use PCRE v2 for optimized fixed-string searchÆvar Arnfjörð Bjarmason, Jun 26, 2019
  85. Johannes SchindelinJun 26, 2019
  86. Junio C HamanoJun 26, 2019
  87. Johannes SchindelinJun 27, 2019
  88. Johannes SchindelinJun 27, 2019
  89. Junio C HamanoJun 27, 2019
  90. Johannes SchindelinJun 28, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.