Marek Zawirski
Posts as marek.zawirski@gmail.com.
145
messages
114
patches posted
0%
of 8 series merged
10
threads started
2008
first message, Mar 22, 2008
Mar 25, 2009
since the latest message
Patch series
Of 8 patch series (re-rolls counted once), 0 landed on master and 8 did not.
- not mergedFix local tracking refs updates during pushAug 28, 2008
- not mergedGive NoRemoteRepositoryException better message in BasePackConnectionAug 28, 2008
- not mergedFetch UI, minor improvements/fixesAug 27, 2008
- not mergedPush GUI, GUI improvements, various jgit stuffAug 20, 2008
- not mergedMake push more verbosive about illegal combination of optionsAug 16, 2008
- not mergedPush implementationJun 27, 2008
- not mergedPackWriter, first usable attemptJun 17, 2008
- not mergedExtensions in core needed by PackWriterv2, Jun 7, 2008
A series is merged when one of its patches matches a commit on master by the same author, by subject. Versions are linked when they share a patch subject. Patches reworded before landing, or applied under someone else's name, count as not merged.
Recent emails
- Re: [PATCH JGIT 1/2] Calculate CRC32 on Pack Index v2
- Re: [GSoC] Git projects for Google Summer of Code 2008 final evaluation
- Re: [JGIT PATCH] Disambiguate "push not supported" from "repository not found"
- Re: [EGIT PATCH 1/3] Give NoRemoteRepositoryException better message in BasePackConnection
- Fix RemoteRefUpdate to delete local tracking ref upon successful deletion
- Add another delete method in RefUpdate, reusing RevWalk
- Fix push's RemoteRefUpdate to always force update local TrackingRefUpdate
- Fix local tracking refs updates during push
- Re: [EGIT PATCH 3/3] Show ErrorDialog fot fatal connection errors in ConfirmationPage
- Re: [EGIT PATCH 2/3] Handle NoRemoteRepositoryException in PushOperation especially
- Show ErrorDialog fot fatal connection errors in ConfirmationPage
- Handle NoRemoteRepositoryException in PushOperation especially
- Give NoRemoteRepositoryException better message in BasePackConnection
- Re: [JGIT PATCH 1/2] Ignore unreadable SSH private keys when autoloading identities
- Re: [EGIT PATCH 0/6] Fetch UI, minor improvements/fixes
- Fetch GUI
- Rename ResultDialog to PushResultDialog
- Add tag fetching strategy selection to fetch version of RefSpecPage
- Handle null remoteName in RefSpecPanel better
- Fix RefSpecPanel to not display mode column in fetch version
- Reduce PushOperationResult contructor visibility, accept null instead
- Fetch UI, minor improvements/fixes
- Re: [EGIT PATCH 00/31] Push GUI, GUI improvements, various jgit stuff
- Re: [EGIT PATCH 00/31] Push GUI, GUI improvements, various jgit stuff
- Fix RefSpecPage formatting
- Fix disappearing "save configuration" label in RefSpecPage
- Fix proposal provider for fetch in RefSpecPanel
- Handle URIs parsing errors in PushAction better
- Emphasize that db is a local one in RemoteRefUpdate
- Remove DEFAULT_DRY_RUN constant from Transport