git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[EGIT PATCH 5/6] Rename ResultDialog to PushResultDialog

From
MZMarek Zawirski <marek.zawirski@gmail.com>
Date
Aug 27, 2008, 18:41 UTC
Message-ID
<1219862506-11075-6-git-send-email-marek.zawirski@gmail.com>
In-Reply-To
<1219862506-11075-5-git-send-email-marek.zawirski@gmail.com>

Let's avoid ambiguity in UIText and other places when we also use FetchResultDialog.

Signed-off-by: Marek Zawirski <marek.zawirski@gmail.com>
---
 .../{ResultDialog.java => PushResultDialog.java}   |    4 ++--
 .../spearce/egit/ui/internal/push/PushWizard.java  |    5 +++--
 2 files changed, 5 insertions(+), 4 deletions(-)
 rename org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/{ResultDialog.java => PushResultDialog.java} (95%)
diff --git a/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/ResultDialog.java b/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushResultDialog.java
similarity index 95%
rename from org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/ResultDialog.java
rename to org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushResultDialog.java
index 920494f..bace9ad 100644
--- a/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/ResultDialog.java
+++ b/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushResultDialog.java
@@ -20,14 +20,14 @@
 import org.spearce.egit.ui.UIText;
 import org.spearce.jgit.lib.Repository;
 
-class ResultDialog extends Dialog {
+class PushResultDialog extends Dialog {
 	private final Repository localDb;
 
 	private final PushOperationResult result;
 
 	private final String destinationString;
 
-	ResultDialog(final Shell parentShell, final Repository localDb,
+	PushResultDialog(final Shell parentShell, final Repository localDb,
 			final PushOperationResult result, final String destinationString) {
 		super(parentShell);
 		setShellStyle(getShellStyle() | SWT.RESIZE);
diff --git a/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushWizard.java b/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushWizard.java
index a5c6339..b2ef5ae 100644
--- a/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushWizard.java
+++ b/org.spearce.egit.ui/src/org/spearce/egit/ui/internal/push/PushWizard.java
@@ -238,8 +238,9 @@ protected IStatus run(final IProgressMonitor monitor) {
 							public void run() {
 								final Shell shell = PlatformUI.getWorkbench()
 										.getActiveWorkbenchWindow().getShell();
-								final Dialog dialog = new ResultDialog(shell,
-										localDb, result, destinationString);
+								final Dialog dialog = new PushResultDialog(
+										shell, localDb, result,
+										destinationString);
 								dialog.open();
 							}
 						});
-- 
1.5.6.3
Previous: Marek ZawirskiNext: Marek Zawirski
Message 6 of 10 in “Fetch UI, minor improvements/fixes”
  1. 0/6 Fetch UI, minor improvements/fixesMarek Zawirski, Aug 27, 2008
  2. 1/6 Reduce PushOperationResult contructor visibility, accept null insteadMarek Zawirski, Aug 27, 2008
  3. 2/6 Fix RefSpecPanel to not display mode column in fetch versionMarek Zawirski, Aug 27, 2008
  4. 3/6 Handle null remoteName in RefSpecPanel betterMarek Zawirski, Aug 27, 2008
  5. 4/6 Add tag fetching strategy selection to fetch version of RefSpecPageMarek Zawirski, Aug 27, 2008
  6. 5/6 Rename ResultDialog to PushResultDialogMarek Zawirski, Aug 27, 2008
  7. 6/6 Fetch GUIMarek Zawirski, Aug 27, 2008
  8. Robin RosenbergAug 27, 2008
  9. Marek ZawirskiAug 27, 2008
  10. Shawn O. PearceAug 27, 2008

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.