threads / patch / 61593

patchadd-i: finally retire add.interactive.useBuiltin

Subject: [PATCH] add-i: finally retire add.interactive.useBuiltin

## tl;dr

3 messages between Jun 5, 2024 and Jun 6, 2024. Diffs are folded; open one to read it.

replies: 2people: 3as markdown or json

Junio C Hamano· Jun 5, 2024, 21:27 UTC · lore

The configuration variable stopped doing anything (other than announcing itself as a variable that does not do anything useful, when it is used) in Git 2.40.

At this point, it is not even worth giving the warning, which was meant to be a way to help users notice they are carrying unused cruft in their configuration files and give them a chance to clean-up.

Let's remove the warning and documentation for it, and truly stop paying attention to it.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
               ---
 Documentation/config/add.txt |  6 ------
 builtin/add.c                |  6 +-----
 t/t3701-add-interactive.sh   | 15 ---------------
 3 files changed, 1 insertion(+), 26 deletions(-)
Show changes to diff +1 −26
diff --git c/Documentation/config/add.txt w/Documentation/config/add.txt
index e0354ceaed..4d753f006e 100644
--- c/Documentation/config/add.txt
+++ w/Documentation/config/add.txt
@@ -5,9 +5,3 @@ add.ignore-errors (deprecated)::
 	option of linkgit:git-add[1].  `add.ignore-errors` is deprecated,
 	as it does not follow the usual naming convention for configuration
 	variables.
-
-add.interactive.useBuiltin::
-	Unused configuration variable. Used in Git versions v2.25.0 to
-	v2.36.0 to enable the built-in version of linkgit:git-add[1]'s
-	interactive mode, which then became the default in Git
-	versions v2.37.0 to v2.39.0.
diff --git c/builtin/add.c w/builtin/add.c
index 3dfcfc5fba..40b61ef90d 100644
--- c/builtin/add.c
+++ w/builtin/add.c
@@ -150,11 +150,7 @@ static int refresh(int verbose, const struct pathspec *pathspec)
 int interactive_add(const char **argv, const char *prefix, int patch)
 {
 	struct pathspec pathspec;
-	int unused, ret;
-
-	if (!git_config_get_bool("add.interactive.usebuiltin", &unused))
-		warning(_("the add.interactive.useBuiltin setting has been removed!\n"
-			  "See its entry in 'git help config' for details."));
+	int ret;
 
 	parse_pathspec(&pathspec, 0,
 		       PATHSPEC_PREFER_FULL |
diff --git c/t/t3701-add-interactive.sh w/t/t3701-add-interactive.sh
index 6624a4f7c0..5d78868ac1 100755
--- c/t/t3701-add-interactive.sh
+++ w/t/t3701-add-interactive.sh
@@ -43,21 +43,6 @@ force_color () {
 	)
 }
 
-test_expect_success 'warn about add.interactive.useBuiltin' '
-	cat >expect <<-\EOF &&
-	warning: the add.interactive.useBuiltin setting has been removed!
-	See its entry in '\''git help config'\'' for details.
-	EOF
-	echo "No changes." >expect.out &&
-
-	for v in = =true =false
-	do
-		git -c "add.interactive.useBuiltin$v" add -p >out 2>actual &&
-		test_cmp expect.out out &&
-		test_cmp expect actual || return 1
-	done
-'
-
 test_expect_success 'unknown command' '
 	test_when_finished "git reset --hard; rm -f command" &&
 	echo W >command &&
Jeff King· Jun 6, 2024, 08:32 UTC · re: Junio C Hamano · lore

Re: [PATCH] add-i: finally retire add.interactive.useBuiltin

On Wed, Jun 05, 2024 at 02:27:21PM -0700, Junio C Hamano wrote:
Show 9 quoted lines
> Let's remove the warning and documentation for it, and truly stop
> paying attention to it.
> 
> Signed-off-by: Junio C Hamano <gitster@pobox.com>
>                ---
>  Documentation/config/add.txt |  6 ------
>  builtin/add.c                |  6 +-----
>  t/t3701-add-interactive.sh   | 15 ---------------
>  3 files changed, 1 insertion(+), 26 deletions(-)
Looks sensible, and the diffstat is very pleasing. :)
-Peff
Patrick Steinhardt· Jun 6, 2024, 09:40 UTC · re: Junio C Hamano · lore

Re: [PATCH] add-i: finally retire add.interactive.useBuiltin

On Wed, Jun 05, 2024 at 02:27:21PM -0700, Junio C Hamano wrote:
Show 11 quoted lines
> The configuration variable stopped doing anything (other than
> announcing itself as a variable that does not do anything useful,
> when it is used) in Git 2.40.  
> 
> At this point, it is not even worth giving the warning, which was
> meant to be a way to help users notice they are carrying unused
> cruft in their configuration files and give them a chance to
> clean-up.
> 
> Let's remove the warning and documentation for it, and truly stop
> paying attention to it.
Makes sense, and the changes look good to me. Thanks!
Patrick

← back to recent threads