git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH] add-i: finally retire add.interactive.useBuiltin

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 5, 2024, 21:27 UTC
Message-ID
<xmqqikynqdvq.fsf@gitster.g>

The configuration variable stopped doing anything (other than announcing itself as a variable that does not do anything useful, when it is used) in Git 2.40.

At this point, it is not even worth giving the warning, which was meant to be a way to help users notice they are carrying unused cruft in their configuration files and give them a chance to clean-up.

Let's remove the warning and documentation for it, and truly stop paying attention to it.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
               ---
 Documentation/config/add.txt |  6 ------
 builtin/add.c                |  6 +-----
 t/t3701-add-interactive.sh   | 15 ---------------
 3 files changed, 1 insertion(+), 26 deletions(-)
diff --git c/Documentation/config/add.txt w/Documentation/config/add.txt
index e0354ceaed..4d753f006e 100644
--- c/Documentation/config/add.txt
+++ w/Documentation/config/add.txt
@@ -5,9 +5,3 @@ add.ignore-errors (deprecated)::
 	option of linkgit:git-add[1].  `add.ignore-errors` is deprecated,
 	as it does not follow the usual naming convention for configuration
 	variables.
-
-add.interactive.useBuiltin::
-	Unused configuration variable. Used in Git versions v2.25.0 to
-	v2.36.0 to enable the built-in version of linkgit:git-add[1]'s
-	interactive mode, which then became the default in Git
-	versions v2.37.0 to v2.39.0.
diff --git c/builtin/add.c w/builtin/add.c
index 3dfcfc5fba..40b61ef90d 100644
--- c/builtin/add.c
+++ w/builtin/add.c
@@ -150,11 +150,7 @@ static int refresh(int verbose, const struct pathspec *pathspec)
 int interactive_add(const char **argv, const char *prefix, int patch)
 {
 	struct pathspec pathspec;
-	int unused, ret;
-
-	if (!git_config_get_bool("add.interactive.usebuiltin", &unused))
-		warning(_("the add.interactive.useBuiltin setting has been removed!\n"
-			  "See its entry in 'git help config' for details."));
+	int ret;
 
 	parse_pathspec(&pathspec, 0,
 		       PATHSPEC_PREFER_FULL |
diff --git c/t/t3701-add-interactive.sh w/t/t3701-add-interactive.sh
index 6624a4f7c0..5d78868ac1 100755
--- c/t/t3701-add-interactive.sh
+++ w/t/t3701-add-interactive.sh
@@ -43,21 +43,6 @@ force_color () {
 	)
 }
 
-test_expect_success 'warn about add.interactive.useBuiltin' '
-	cat >expect <<-\EOF &&
-	warning: the add.interactive.useBuiltin setting has been removed!
-	See its entry in '\''git help config'\'' for details.
-	EOF
-	echo "No changes." >expect.out &&
-
-	for v in = =true =false
-	do
-		git -c "add.interactive.useBuiltin$v" add -p >out 2>actual &&
-		test_cmp expect.out out &&
-		test_cmp expect actual || return 1
-	done
-'
-
 test_expect_success 'unknown command' '
 	test_when_finished "git reset --hard; rm -f command" &&
 	echo W >command &&
Next: Jeff King
Message 1 of 3 in “add-i: finally retire add.interactive.useBuiltin”
  1. add-i: finally retire add.interactive.useBuiltinJunio C Hamano, Jun 5, 2024
  2. Jeff KingJun 6, 2024
  3. Patrick SteinhardtJun 6, 2024

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.