{"thread":{"id":"61593","subject":"[PATCH] add-i: finally retire add.interactive.useBuiltin","startedAt":"2024-06-05T21:27:27Z","lastAt":"2024-06-06T09:40:50Z","messageCount":3,"participants":["Junio C Hamano","Jeff King","Patrick Steinhardt"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"496399","messageId":"xmqqikynqdvq.fsf@gitster.g","threadId":"61593","inReplyTo":null,"subject":"[PATCH] add-i: finally retire add.interactive.useBuiltin","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2024-06-05T21:27:21Z","receivedAt":"2024-06-05T21:27:27Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"The configuration variable stopped doing anything (other than\nannouncing itself as a variable that does not do anything useful,\nwhen it is used) in Git 2.40.  \n\nAt this point, it is not even worth giving the warning, which was\nmeant to be a way to help users notice they are carrying unused\ncruft in their configuration files and give them a chance to\nclean-up.\n\nLet's remove the warning and documentation for it, and truly stop\npaying attention to it.\n\nSigned-off-by: Junio C Hamano <gitster@pobox.com>\n               ---\n Documentation/config/add.txt |  6 ------\n builtin/add.c                |  6 +-----\n t/t3701-add-interactive.sh   | 15 ---------------\n 3 files changed, 1 insertion(+), 26 deletions(-)\n\ndiff --git c/Documentation/config/add.txt w/Documentation/config/add.txt\nindex e0354ceaed..4d753f006e 100644\n--- c/Documentation/config/add.txt\n+++ w/Documentation/config/add.txt\n@@ -5,9 +5,3 @@ add.ignore-errors (deprecated)::\n \toption of linkgit:git-add[1].  `add.ignore-errors` is deprecated,\n \tas it does not follow the usual naming convention for configuration\n \tvariables.\n-\n-add.interactive.useBuiltin::\n-\tUnused configuration variable. Used in Git versions v2.25.0 to\n-\tv2.36.0 to enable the built-in version of linkgit:git-add[1]'s\n-\tinteractive mode, which then became the default in Git\n-\tversions v2.37.0 to v2.39.0.\ndiff --git c/builtin/add.c w/builtin/add.c\nindex 3dfcfc5fba..40b61ef90d 100644\n--- c/builtin/add.c\n+++ w/builtin/add.c\n@@ -150,11 +150,7 @@ static int refresh(int verbose, const struct pathspec *pathspec)\n int interactive_add(const char **argv, const char *prefix, int patch)\n {\n \tstruct pathspec pathspec;\n-\tint unused, ret;\n-\n-\tif (!git_config_get_bool(\"add.interactive.usebuiltin\", &unused))\n-\t\twarning(_(\"the add.interactive.useBuiltin setting has been removed!\\n\"\n-\t\t\t  \"See its entry in 'git help config' for details.\"));\n+\tint ret;\n \n \tparse_pathspec(&pathspec, 0,\n \t\t       PATHSPEC_PREFER_FULL |\ndiff --git c/t/t3701-add-interactive.sh w/t/t3701-add-interactive.sh\nindex 6624a4f7c0..5d78868ac1 100755\n--- c/t/t3701-add-interactive.sh\n+++ w/t/t3701-add-interactive.sh\n@@ -43,21 +43,6 @@ force_color () {\n \t)\n }\n \n-test_expect_success 'warn about add.interactive.useBuiltin' '\n-\tcat >expect <<-\\EOF &&\n-\twarning: the add.interactive.useBuiltin setting has been removed!\n-\tSee its entry in '\\''git help config'\\'' for details.\n-\tEOF\n-\techo \"No changes.\" >expect.out &&\n-\n-\tfor v in = =true =false\n-\tdo\n-\t\tgit -c \"add.interactive.useBuiltin$v\" add -p >out 2>actual &&\n-\t\ttest_cmp expect.out out &&\n-\t\ttest_cmp expect actual || return 1\n-\tdone\n-'\n-\n test_expect_success 'unknown command' '\n \ttest_when_finished \"git reset --hard; rm -f command\" &&\n \techo W >command &&\n"},{"id":"496468","messageId":"20240606083257.GF658959@coredump.intra.peff.net","threadId":"61593","inReplyTo":"xmqqikynqdvq.fsf@gitster.g","subject":"Re: [PATCH] add-i: finally retire add.interactive.useBuiltin","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2024-06-06T08:32:57Z","receivedAt":"2024-06-06T08:32:58Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Wed, Jun 05, 2024 at 02:27:21PM -0700, Junio C Hamano wrote:\n\n> Let's remove the warning and documentation for it, and truly stop\n> paying attention to it.\n> \n> Signed-off-by: Junio C Hamano <gitster@pobox.com>\n>                ---\n>  Documentation/config/add.txt |  6 ------\n>  builtin/add.c                |  6 +-----\n>  t/t3701-add-interactive.sh   | 15 ---------------\n>  3 files changed, 1 insertion(+), 26 deletions(-)\n\nLooks sensible, and the diffstat is very pleasing. :)\n\n-Peff\n"},{"id":"496475","messageId":"ZmGEHuNZsfgczr7X@tanuki","threadId":"61593","inReplyTo":"xmqqikynqdvq.fsf@gitster.g","subject":"Re: [PATCH] add-i: finally retire add.interactive.useBuiltin","fromName":"Patrick Steinhardt","fromEmail":"ps@pks.im","sentAt":"2024-06-06T09:40:46Z","receivedAt":"2024-06-06T09:40:50Z","isPatch":true,"sender":{"key":"ps@pks.im","avatar":"https://avatars.githubusercontent.com/u/4056630?v=4"},"body":"On Wed, Jun 05, 2024 at 02:27:21PM -0700, Junio C Hamano wrote:\n> The configuration variable stopped doing anything (other than\n> announcing itself as a variable that does not do anything useful,\n> when it is used) in Git 2.40.  \n> \n> At this point, it is not even worth giving the warning, which was\n> meant to be a way to help users notice they are carrying unused\n> cruft in their configuration files and give them a chance to\n> clean-up.\n> \n> Let's remove the warning and documentation for it, and truly stop\n> paying attention to it.\n\nMakes sense, and the changes look good to me. Thanks!\n\nPatrick\n"}]}