threads / patch / 43805

patchreceive-pack: use FLEX_ALLOC_MEM in queue_command()

Subject: [PATCH] receive-pack: use FLEX_ALLOC_MEM in queue_command()

## tl;dr

2 messages between Aug 13, 2016 and Aug 14, 2016. Diffs are folded; open one to read it.

replies: 1people: 2as markdown or json

René Scharfe· Aug 13, 2016, 15:38 UTC · lore

Use the macro FLEX_ALLOC_MEM instead of open-coding it. This shortens and simplifies the code a bit.

Signed-off-by: Rene Scharfe <l.s.r@web.de>
---
 builtin/receive-pack.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)
Show changes to builtin/receive-pack.c +1 −3
diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c
index 92e1213..011db00 100644
--- a/builtin/receive-pack.c
+++ b/builtin/receive-pack.c
@@ -1478,11 +1478,9 @@ static struct command **queue_command(struct command **tail,
 
 	refname = line + 82;
 	reflen = linelen - 82;
-	cmd = xcalloc(1, st_add3(sizeof(struct command), reflen, 1));
+	FLEX_ALLOC_MEM(cmd, ref_name, refname, reflen);
 	hashcpy(cmd->old_sha1, old_sha1);
 	hashcpy(cmd->new_sha1, new_sha1);
-	memcpy(cmd->ref_name, refname, reflen);
-	cmd->ref_name[reflen] = '\0';
 	*tail = cmd;
 	return &cmd->next;
 }
-- 
2.9.3
Jeff King· Aug 13, 2016, 18:34 UTC · re: René Scharfe · lore

Re: [PATCH] receive-pack: use FLEX_ALLOC_MEM in queue_command()

On Sat, Aug 13, 2016 at 05:38:56PM +0200, René Scharfe wrote:
> Use the macro FLEX_ALLOC_MEM instead of open-coding it.  This shortens
> and simplifies the code a bit.

Thanks, looks good (I obviously missed a few opportunities for conversion during the initial introduction of FLEX_ALLOC simply by not noticing; I don't think there is any more reason that this one was not converted).

-Peff

← back to recent threads