# [PATCH] receive-pack: use FLEX_ALLOC_MEM in queue_command()

2 messages from 2016-08-13 to 2016-08-14. Participants: René Scharfe, Jeff King.
Thread: https://gitlist.dev/t/43805

## René Scharfe, 2016-08-13 15:38

Subject: [PATCH] receive-pack: use FLEX_ALLOC_MEM in queue_command()
Message-ID: <57AF3F10.3050508@web.de>
URL: https://gitlist.dev/e/57AF3F10.3050508%40web.de

```
Use the macro FLEX_ALLOC_MEM instead of open-coding it.  This shortens
and simplifies the code a bit.

Signed-off-by: Rene Scharfe <l.s.r@web.de>
---
 builtin/receive-pack.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c
index 92e1213..011db00 100644
--- a/builtin/receive-pack.c
+++ b/builtin/receive-pack.c
@@ -1478,11 +1478,9 @@ static struct command **queue_command(struct command **tail,
 
 	refname = line + 82;
 	reflen = linelen - 82;
-	cmd = xcalloc(1, st_add3(sizeof(struct command), reflen, 1));
+	FLEX_ALLOC_MEM(cmd, ref_name, refname, reflen);
 	hashcpy(cmd->old_sha1, old_sha1);
 	hashcpy(cmd->new_sha1, new_sha1);
-	memcpy(cmd->ref_name, refname, reflen);
-	cmd->ref_name[reflen] = '\0';
 	*tail = cmd;
 	return &cmd->next;
 }
-- 
2.9.3


```

## Jeff King, 2016-08-13 18:34

Subject: Re: [PATCH] receive-pack: use FLEX_ALLOC_MEM in queue_command()
Message-ID: <20160813183429.lhgl3qfx7gf4duvj@sigill.intra.peff.net>
URL: https://gitlist.dev/e/20160813183429.lhgl3qfx7gf4duvj%40sigill.intra.peff.net
In-Reply-To: <57AF3F10.3050508@web.de>

```
On Sat, Aug 13, 2016 at 05:38:56PM +0200, René Scharfe wrote:

> Use the macro FLEX_ALLOC_MEM instead of open-coding it.  This shortens
> and simplifies the code a bit.

Thanks, looks good (I obviously missed a few opportunities for
conversion during the initial introduction of FLEX_ALLOC simply by not
noticing; I don't think there is any more reason that this one was not
converted).

-Peff

```
