Re: [PATCH v3 4/4] connect: Add the envvar GIT_SSH_VARIANT and ssh.variant config
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 1, 2017, 22:33 UTC
- Message-ID
- <xmqqzii5mthp.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <alpine.DEB.2.20.1702012319460.3496@virtualbox>
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> That leaves the "putty" case in handle_ssh_variant(), does it not? Was it > not your specific objection that that is the case?
Yup, you can remove that while you reroll.
> No worries, I will let this simmer for a while. Your fixup has a lot of > duplicated code (so much for maintainability as an important goal... ;-)) > and I will have to think about it. My immediate thinking is to *not* > duplicate code,...
You need to realize that the namespaces of the configuration and the command names are distinct. There is no code duplication.