Re: [PATCH 3/3] diff: convert flags to be stored in bitfields
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Oct 30, 2017, 00:29 UTC
- Message-ID
- <xmqqzi898olb.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <xmqqk1zeafaq.fsf@gitster.mtv.corp.google.com>
Junio C Hamano <gitster@pobox.com> writes:
> I still haven't brought myself to like the structure being passed by > value and the singleton diff_flags_cleared thing, but I suspect that > we may get used to them once we start using these. I dunno.
Just bikeshedding, but I just had to prepare an evil merge to add a new use of diff_flags_cleared to a codepath that evolved in a topic still in flight, and realized that I really hate the name. Perhaps I wouldn't have hated it so much if it were named diff_flags_none or diff_flags_empty, I guess.