Re: [PATCH 3/3] diff: convert flags to be stored in bitfields
- From
- Brandon Williams <bmwill@google.com>
- Date
- Oct 30, 2017, 19:39 UTC
- Message-ID
- <20171030193924.GC125460@google.com>
- In-Reply-To
- <xmqqzi898olb.fsf@gitster.mtv.corp.google.com>
On 10/30, Junio C Hamano wrote:
Show 11 quoted lines
> Junio C Hamano <gitster@pobox.com> writes: > > > I still haven't brought myself to like the structure being passed by > > value and the singleton diff_flags_cleared thing, but I suspect that > > we may get used to them once we start using these. I dunno. > > Just bikeshedding, but I just had to prepare an evil merge to add a > new use of diff_flags_cleared to a codepath that evolved in a topic > still in flight, and realized that I really hate the name. Perhaps > I wouldn't have hated it so much if it were named diff_flags_none or > diff_flags_empty, I guess.
I have a new version of the series I'll send out and i ended up dropping it entirely. Didn't even need a clear function because I was able to drop the touched stuff and it would have only been used inside of builtin/log.c to clear the touched flags.
-- Brandon Williams