Re: [PATCH 00/11] CodeQL-inspired fixes
Jeff King <peff@peff.net> writes:
Show 21 quoted lines
> On Thu, May 15, 2025 at 01:11:38PM +0000, Johannes Schindelin via GitGitGadget wrote:
>
>> CodeQL [https://codeql.github.com/] pointed out a couple of issues, which
>> are addressed in this patch series.
>>
>> Johannes Schindelin (11):
>> commit: simplify code
>> fetch: carefully clear local variable's address after use
>> commit-graph: avoid malloc'ing a local variable
>> upload-pack: rename `enum` to reflect the operation
>> has_dir_name(): make code more obvious
>> fetch: avoid unnecessary work when there is no current branch
>> Avoid redundant conditions
>> trace2: avoid "futile conditional"
>> commit-graph: avoid using stale stack addresses
>> bundle-uri: avoid using undefined output of `sscanf()`
>> sequencer: stop pretending that an assignment is a condition
>
> I read through all of these and didn't find anything incorrect. I did
> leave a few comments that might or might not be worth following up on.
> Thanks for fixing these.
Yup, I also looked at them and didn't see any incorrect updates.