Re: [PATCH 00/11] CodeQL-inspired fixes
- From
Jeff King <peff@peff.net>
- Date
- May 15, 2025, 20:26 UTC
- Message-ID
- <20250515202652.GM3320240@coredump.intra.peff.net>
- In-Reply-To
- <pull.1891.git.1747314709.gitgitgadget@gmail.com>
On Thu, May 15, 2025 at 01:11:38PM +0000, Johannes Schindelin via GitGitGadget wrote:
Show 15 quoted lines
> CodeQL [https://codeql.github.com/] pointed out a couple of issues, which > are addressed in this patch series. > > Johannes Schindelin (11): > commit: simplify code > fetch: carefully clear local variable's address after use > commit-graph: avoid malloc'ing a local variable > upload-pack: rename `enum` to reflect the operation > has_dir_name(): make code more obvious > fetch: avoid unnecessary work when there is no current branch > Avoid redundant conditions > trace2: avoid "futile conditional" > commit-graph: avoid using stale stack addresses > bundle-uri: avoid using undefined output of `sscanf()` > sequencer: stop pretending that an assignment is a condition
I read through all of these and didn't find anything incorrect. I did leave a few comments that might or might not be worth following up on. Thanks for fixing these.
-Peff