Re: [PATCH 1/3] t3404: preserve test_tick state across short SHA-1 collision test
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 26, 2013, 05:29 UTC
- Message-ID
- <xmqqwqn9j9yz.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <20130825085318.GV2882@elie.Belkin>
Jonathan Nieder <jrnieder@gmail.com> writes:
Show 29 quoted lines
> Eric Sunshine wrote: >> On Sun, Aug 25, 2013 at 1:55 AM, Jonathan Nieder <jrnieder@gmail.com> wrote: > >>> Would be clearer if the code in a subshell were indented: >>> >>> ( >>> unset test_tick && >>> test_commit ... >>> ) >> >> I considered it, but decided against it for a couple reasons: >> >> * In this script, there already is a mix between the two styles: >> indented vs. unindented. >> >> * In this particular patch, the test_commit line creating commit3 >> wrapped beyond 80 columns when indented. > > I'm just one person, but I find the indented form way more readable. > Long lines or lines with \ continuation are not a big deal. > > [...] >> Should this be worth a re-roll? > > Since the file already has a mixture of styles, if there's no other > reason to reroll, I'd suggest leaving it alone. > > The next time it bugs me or someone else, that person can write a > patch that cleans up the whole file on top. :)
Yeah, I think we saw "style modernization" patches to some test scripts during the last cycle. This one and the rest may want to go through a similar modernization, but it can be done after a real change like the proposed one matures.
Thanks.