Re: [PATCH v4 4/7] parse-options: rename `OPT_MAGNITUDE()` to `OPT_UNSIGNED()`
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 17, 2025, 15:17 UTC
- Message-ID
- <xmqqv7r2es1t.fsf@gitster.g>
- In-Reply-To
- <20250417-b4-pks-parse-options-integers-v4-4-9cbc76b61cfe@pks.im>
Patrick Steinhardt <ps@pks.im> writes:
Show 8 quoted lines
> With the preceding commit, `OPT_INTEGER()` has learned to support unit > factors. Consequently, the major differencen between `OPT_INTEGER()` and > `OPT_MAGNITUDE()` isn't the support of unit factors anymore, as both of > them do support them now. Instead, the difference is that one handles > signed and the other handles unsigned integers. > > Adapt the name of `OPT_MAGNITUDE()` accordingly by renaming it to > `OPT_UNSIGNED()`.
Very good move. It would have been very confusing if a new developer had to choose between INTEGER and MAGNITUDE, and this change nicely removes that "Huh?" factor.
Thanks.