git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 0/4] breaking changes: switch default initial branch name to "main"

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 17, 2025, 09:22 UTC
Message-ID
<xmqqv7lhigb7.fsf@gitster.g>
In-Reply-To
<xmqq4itarqfd.fsf@gitster.g>
Junio C Hamano <gitster@pobox.com> writes:
Show 26 quoted lines
> Phillip Wood <phillip.wood123@gmail.com> writes:
>
>> Changes since V2:
>> Patch 1: reworded documentation
>> Patch 3: fixed typo in commit message
>> Patch 4: added helper function to initialise repository
>
> Everything I saw in the patch looked good.
>
>> I'm still on the fence about the suggestion to add some advice on how
>> to rename the branch after it is created in order to help users who
>> are following tutorials using "master" rather than "main". One the
>> one hand I can see that would be helpful, on the other it is pretty
>> annoying to everyone else.
>
> Hmph.  I do not see why we want to be quiet and do not want to give
> "Now we created 'main', which may not match an existing tutorial you
> are trying to follow.  Here is a way to use a different name to let
> you continue with the tutorial." after annoying everybody with
> "Sorry but we created 'master', which may not match your taste.
> Here is how you arrange it to be different" for more than a few
> releases already.
>
> IOW, I do not see annoyance is a valid argument against or for a
> corresponding message to help the users across behaviour change
> boundary.

I do not want to see a viable topic left for too long without getting completed, so here is my attempt.

Earlier I thought we should use a separate advice.* variable to squelch, but after thinking it again for a while, I think reusing the one we have been using gives exactly what we want, so this just changes the contents of the message after the switchover. We would need to retire the message after a while.

--- >8 ---
Subject: [PATCH 5/4] initial branch: give hints after switching the default name

It is likely that those who came to Git after 3.0 switched the default initial branch name to 'main' would still try to follow tutorials that were written before 3.0 happened and with the assumption that the tool would call the initial branch 'master'.

To help these new users after 3.0 boundary, let's retain one part of the hint we will be giving before the default changes, namely, how to rename the branch an unconfigured Git has created just once.

We do this without telling them how to permanently configure the default name of the initial branch, and that design choice is very much deliberate. The whole point of switching the default name was because we did not want to force individual users to configure their default branch name but while the hard wired default was 'master', they _had_ to configure it away from 'master' in order to conform to the recent norm, and a hint that tells them how to do so is useful.

But once the default is renamed to 'main', that no longer is true. A narrower audience who are new users that follow an instruction that assumes the initial branch name is 'master' would only need to learn "here is how to change the branch name to match the tutorial you are following in the repository you created for practice", and "here is how you keep creating repositories with the first branch with a name everybody hates" is unnecessary.

It also needs to be noted thta the advise token to squelch the message is the same advice.defaultBranchName as before, which is also very much deliberate. The users who do have that configured are those who _have_ been using Git since before 3.0, and they are not the target audience for the new advice message. Reusing the same advise token ensures that they do not have to turn the message off.

Signed-off-by: Junio C Hamano <gitster@pobox.com>
---
 advice.c         |  2 --
 advice.h         |  4 +---
 refs.c           | 12 ++++++++++--
 t/t0000-basic.sh |  3 ++-
 t/t0001-init.sh  | 14 +++++++-------
 5 files changed, 20 insertions(+), 15 deletions(-)
diff --git c/advice.c w/advice.c
index 48c49ee414..e5f0ff8449 100644
--- c/advice.c
+++ w/advice.c
@@ -51,9 +51,7 @@ static struct {
 	[ADVICE_AM_WORK_DIR] 				= { "amWorkDir" },
 	[ADVICE_CHECKOUT_AMBIGUOUS_REMOTE_BRANCH_NAME] 	= { "checkoutAmbiguousRemoteBranchName" },
 	[ADVICE_COMMIT_BEFORE_MERGE]			= { "commitBeforeMerge" },
-#ifndef WITH_BREAKING_CHANGES
 	[ADVICE_DEFAULT_BRANCH_NAME]			= { "defaultBranchName" },
-#endif /* WITH_BREAKING_CHANGES */
 	[ADVICE_DETACHED_HEAD]				= { "detachedHead" },
 	[ADVICE_DIVERGING]				= { "diverging" },
 	[ADVICE_FETCH_SET_HEAD_WARN]			= { "fetchRemoteHEADWarn" },
diff --git c/advice.h w/advice.h
index fc1dc87204..8def280688 100644
--- c/advice.h
+++ w/advice.h
@@ -18,9 +18,7 @@ enum advice_type {
 	ADVICE_AM_WORK_DIR,
 	ADVICE_CHECKOUT_AMBIGUOUS_REMOTE_BRANCH_NAME,
 	ADVICE_COMMIT_BEFORE_MERGE,
-#ifndef WITH_BREAKING_CHANGES
-	ADVICE_DEFAULT_BRANCH_NAME,
-#endif /* WITH_BREAKING_CHANGES */
+	ADVICE_DEFAULT_BRANCH_NAME, /* To be retired sometime after Git 3.0 */
 	ADVICE_DETACHED_HEAD,
 	ADVICE_DIVERGING,
 	ADVICE_FETCH_SET_HEAD_WARN,
diff --git c/refs.c w/refs.c
index 149a8d1cec..5e5a41ec01 100644
--- c/refs.c
+++ w/refs.c
@@ -641,9 +641,17 @@ static const char default_branch_name_advice[] = N_(
 "\n"
 "\tgit branch -m <name>\n"
 );
+#else
+static const char default_branch_name_advice[] = N_(
+"Using '%s' as the name for the initial branch since Git 3.0.\n"
+"If you expected Git to create 'master', you can rename the just-created\n"
+"branch can be renamed via this command:\n"
+"\n"
+"\tgit branch -m master\n"
+);
 #endif /* WITH_BREAKING_CHANGES */
 
-char *repo_default_branch_name(struct repository *r, MAYBE_UNUSED int quiet)
+char *repo_default_branch_name(struct repository *r, int quiet)
 {
 	const char *config_key = "init.defaultbranch";
 	const char *config_display_key = "init.defaultBranch";
@@ -660,10 +668,10 @@ char *repo_default_branch_name(struct repository *r, MAYBE_UNUSED int quiet)
 		ret = xstrdup("main");
 #else
 		ret = xstrdup("master");
+#endif /* WITH_BREAKING_CHANGES */
 		if (!quiet)
 			advise_if_enabled(ADVICE_DEFAULT_BRANCH_NAME,
 					  _(default_branch_name_advice), ret);
-#endif /* WITH_BREAKING_CHANGES */
 	}
 
 	full_ref = xstrfmt("refs/heads/%s", ret);
diff --git c/t/t0000-basic.sh w/t/t0000-basic.sh
index 2b63e1c86c..54ed80ebd4 100755
--- c/t/t0000-basic.sh
+++ w/t/t0000-basic.sh
@@ -220,7 +220,8 @@ test_expect_success 'subtest: --verbose option' '
 	test_done
 	EOF
 	mv t1234-verbose/err t1234-verbose/err+ &&
-	grep -v "^Initialized empty" t1234-verbose/err+ >t1234-verbose/err &&
+	grep -v -e "^Initialized empty" -e "^hint:" t1234-verbose/err+ \
+		>t1234-verbose/err &&
 	check_sub_test_lib_test_err t1234-verbose \
 		<<-\EOF_OUT 3<<-\EOF_ERR
 	> ok 1 - passing test
diff --git c/t/t0001-init.sh w/t/t0001-init.sh
index df0040b9ac..5fe7b8c674 100755
--- c/t/t0001-init.sh
+++ w/t/t0001-init.sh
@@ -562,9 +562,9 @@ test_expect_success 'init warns about invalid init.defaultObjectFormat' '
 	test_when_finished "rm -rf repo" &&
 	test_config_global init.defaultObjectFormat garbage &&
 
-	echo "warning: unknown hash algorithm ${SQ}garbage${SQ}" >expect &&
+	expect="warning: unknown hash algorithm ${SQ}garbage${SQ}" &&
 	git init repo 2>err &&
-	test_cmp expect err &&
+	test_grep "$expect" err &&
 
 	git -C repo rev-parse --show-object-format >actual &&
 	echo $GIT_DEFAULT_HASH >expected &&
@@ -649,9 +649,9 @@ test_expect_success 'init warns about invalid init.defaultRefFormat' '
 	test_when_finished "rm -rf repo" &&
 	test_config_global init.defaultRefFormat garbage &&
 
-	echo "warning: unknown ref storage format ${SQ}garbage${SQ}" >expect &&
+	expect="warning: unknown ref storage format ${SQ}garbage${SQ}" &&
 	git init repo 2>err &&
-	test_cmp expect err &&
+	test_grep "$expect" err &&
 
 	git -C repo rev-parse --show-ref-format >actual &&
 	echo $GIT_DEFAULT_REF_FORMAT >expected &&
@@ -868,18 +868,18 @@ test_expect_success 'overridden default initial branch name (config)' '
 	grep nmb actual
 '
 
-test_expect_success !WITH_BREAKING_CHANGES 'advice on unconfigured init.defaultBranch' '
+test_expect_success 'advice on unconfigured init.defaultBranch' '
 	GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME= git -c color.advice=always \
 		init unconfigured-default-branch-name 2>err &&
 	test_decode_color <err >decoded &&
 	test_grep "<YELLOW>hint: " decoded
 '
 
-test_expect_success 'advice on unconfigured init.defaultBranch disabled' '
+test_expect_success 'advice on unconfigured init.defaultBranch can be disabled' '
 	test_when_finished "rm -rf no-advice" &&
 
 	GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME= \
-		git -c advice.defaultBranchName=false init no-advice 2>err &&
+	git -c advice.defaultBranchName=false init no-advice 2>err &&
 	test_grep ! "hint: " err
 '
 
Previous: Junio C HamanoNext: Kristoffer Haugsbakk
Message 47 of 56 in “breaking changes: switch default initial branch name to "main"”
  1. 0/6 breaking changes: switch default initial branch name to "main"Phillip Wood, Aug 27, 2025
  2. 1/6 t0018: switch default branch name to mainPhillip Wood, Aug 27, 2025
  3. Junio C HamanoAug 27, 2025
  4. Phillip WoodAug 28, 2025
  5. Junio C HamanoAug 28, 2025
  6. brian m. carlsonAug 28, 2025
  7. 3/6 t9902: switch default branch name to mainPhillip Wood, Aug 27, 2025
  8. 2/6 t4013: switch default branch name to mainPhillip Wood, Aug 27, 2025
  9. 4/6 t0613: stop setting default initial branchPhillip Wood, Aug 27, 2025
  10. Junio C HamanoAug 27, 2025
  11. 5/6 t1403: remove dependency on GIT_TEST_DEFAULT_INITIAL_BRANCH_NAMEPhillip Wood, Aug 27, 2025
  12. 6/6 breaking-changes: switch default branch to mainPhillip Wood, Aug 27, 2025
  13. Junio C HamanoAug 27, 2025
  14. Patrick SteinhardtSep 2, 2025
  15. Phillip WoodSep 2, 2025
  16. Patrick SteinhardtSep 3, 2025
  17. Phillip WoodSep 3, 2025
  18. Patrick SteinhardtSep 3, 2025
  19. Junio C HamanoSep 3, 2025
  20. Patrick SteinhardtSep 4, 2025
  21. Phillip WoodSep 4, 2025
  22. Patrick SteinhardtSep 5, 2025
  23. Phillip WoodSep 4, 2025
  24. Johannes SchindelinAug 28, 2025
  25. 0/4 breaking changes: switch default initial branch name to "main"Phillip Wood, Sep 4, 2025
  26. 1/4 breaking-changes: switch default branch to mainPhillip Wood, Sep 4, 2025
  27. Junio C HamanoSep 4, 2025
  28. Phillip WoodSep 5, 2025
  29. Junio C HamanoSep 5, 2025
  30. 3/4 t9902: switch default branch name to mainPhillip Wood, Sep 4, 2025
  31. Junio C HamanoSep 4, 2025
  32. Phillip WoodSep 5, 2025
  33. Patrick SteinhardtSep 5, 2025
  34. Phillip WoodSep 9, 2025
  35. 2/4 t4013: switch default branch name to mainPhillip Wood, Sep 4, 2025
  36. 4/4 t0613: stop setting default initial branchPhillip Wood, Sep 4, 2025
  37. Junio C HamanoSep 4, 2025
  38. Phillip WoodSep 5, 2025
  39. Junio C HamanoSep 4, 2025
  40. Phillip WoodSep 4, 2025
  41. 0/4 breaking changes: switch default initial branch name to "main"Phillip Wood, Sep 10, 2025
  42. 1/4 breaking-changes: switch default branch to mainPhillip Wood, Sep 10, 2025
  43. 2/4 t4013: switch default branch name to mainPhillip Wood, Sep 10, 2025
  44. 3/4 t9902: switch default branch name to mainPhillip Wood, Sep 10, 2025
  45. 4/4 t0613: stop setting default initial branchPhillip Wood, Sep 10, 2025
  46. Junio C HamanoSep 10, 2025
  47. Junio C HamanoSep 17, 2025
  48. Kristoffer HaugsbakkSep 17, 2025
  49. Junio C HamanoSep 17, 2025
  50. Phillip WoodSep 17, 2025
  51. Junio C HamanoSep 17, 2025
  52. Junio C HamanoSep 17, 2025
  53. Phillip WoodSep 18, 2025
  54. 5/4 initial branch: give hints after switching the default nameJunio C Hamano, Sep 17, 2025
  55. Phillip WoodSep 18, 2025
  56. Junio C HamanoSep 18, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.