Re: [PATCH 1/2] revision: add rdiff_other_arg to rev_info
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Sep 23, 2025, 21:18 UTC
- Message-ID
- <xmqqtt0sookw.fsf@gitster.g>
- In-Reply-To
- <f1da0f06-e57c-4abd-b9ce-ef3fd5ce2037@app.fastmail.com>
"Kristoffer Haugsbakk" <kristofferhaugsbakk@fastmail.com> writes:
Show 10 quoted lines
>>> Could it be as simple as `log_arg` or `log_args`? >> >> Yeah, that is much better than "other" (where it is unclear what are >> the "primary" things that "others" are in contrast). > > I remember looking at the code and having that realization: Oh, *other* > is *log*. Huh. > > ... Maybe specifically `log_args` since it’s a `strvec`? `git grep > 'struct strvec'` seems to give me a lot of plural (style).
If you were asking me about singular vs plural, sorry, I didn't even realize that was the quesiton being asked.
My personal preference is to name arrays singular so that you can name its 0th element by saying dog[0], not dogs[0]. "dog[1] and dog[2] are friends" not dogs[1] and dogs[2]. An exception is when most of the time you use the array as a single unit as a collection, passing it around in the call chain, rarely addressing each individual element. I am OK to see such an array called plural (but of course, singular names are always fine)..
An instance of "struct strvec" may fall into the same category as the latter. A single "struct strvec args" may be used as a collection of arguments passed to the program .
So, log_args is fine by me.