git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/2] revision: add rdiff_other_arg to rev_info

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 23, 2025, 17:35 UTC
Message-ID
<xmqqa52loyvq.fsf@gitster.g>
In-Reply-To
<ba9b7fb2-c990-44fb-a506-0800d02854a9@app.fastmail.com>
"Kristoffer Haugsbakk" <kristofferhaugsbakk@fastmail.com> writes:
Show 30 quoted lines
> On Mon, Sep 22, 2025, at 23:58, Junio C Hamano wrote:
>> kristofferhaugsbakk@fastmail.com writes:
>>
>>> git-format-patch(1) is supposed to treat Git notes the same between
>>> notes output beneath the commit message and the notes output for the
>>> range-diff.
>>
>> Is this an opinion, or are there things that existing pieces of code
>> already do to achieve such a behaviour already?
>
> What I mean is that
>
>     Notes (...)
>
> Beneath the commit message and
>
>     ### Notes (...) ###
>
> In the range-diff should be from the same namespaces. It shouldn’t be,
> for example:
>
>     Notes (presentation):
>
> Beneath the commit message while the range-diff has:
>
>     ### Notes (testing) ###
>     ...
>     ### Notes (scratchpad) ###
>
> That’s the point of passing `--notes` to range-diff.

OK. So it is more like "range-diff is supposed to show comparison of pairs of patches; if format-patch shows one set of notes after three-dash lines in its output, range-diff invoked by format-patch to compare its patches with another set of patches should also be comparing patches generated with the same set of notes". That makes sense to me.

> Thanks for the explanation.  I’ve added `.rdiff_other_arg = STRVEC_INIT
> \` to `REV_INFO_INIT`.

Yup, I think I already have a fix-up patch mixed in your series in the integration result I pushed out last night.

> Could it be as simple as `log_arg` or `log_args`?

Yeah, that is much better than "other" (where it is unclear what are the "primary" things that "others" are in contrast).

Thanks.
Previous: Kristoffer HaugsbakkNext: Kristoffer Haugsbakk
Message 5 of 15 in “format-patch: handle range-diff on notes correctly for single patches”
  1. 0/2 format-patch: handle range-diff on notes correctly for single patcheskristofferhaugsbakk@fastmail.com, Sep 22, 2025
  2. 1/2 revision: add rdiff_other_arg to rev_infokristofferhaugsbakk@fastmail.com, Sep 22, 2025
  3. Junio C HamanoSep 22, 2025
  4. Kristoffer HaugsbakkSep 23, 2025
  5. Junio C HamanoSep 23, 2025
  6. Kristoffer HaugsbakkSep 23, 2025
  7. Junio C HamanoSep 23, 2025
  8. 2/2 format-patch: handle range-diff on notes correctly for single patcheskristofferhaugsbakk@fastmail.com, Sep 22, 2025
  9. Junio C HamanoSep 22, 2025
  10. Kristoffer HaugsbakkSep 23, 2025
  11. Junio C HamanoSep 23, 2025
  12. 0/3 format-patch: handle range-diff on notes correctly for single patcheskristofferhaugsbakk@fastmail.com, Sep 25, 2025
  13. 1/3 range-diff: rename other_arg to log_argkristofferhaugsbakk@fastmail.com, Sep 25, 2025
  14. 2/3 revision: add rdiff_log_arg to rev_infokristofferhaugsbakk@fastmail.com, Sep 25, 2025
  15. 3/3 format-patch: handle range-diff on notes correctly for single patcheskristofferhaugsbakk@fastmail.com, Sep 25, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.