Re: [PATCH][GSoC] parse-options: Add OPT_SET_INT_NONEG.
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 12, 2014, 18:30 UTC
- Message-ID
- <xmqqr467mfrg.fsf@gitster.dls.corp.google.com>
- In-Reply-To
- <CACsJy8Dq5QyZdzCtew0qF37qThH8+05iTrD-ZOeBgbEukmCY5Q@mail.gmail.com>
Duy Nguyen <pclouds@gmail.com> writes:
Show 9 quoted lines
> By convention, no full stop in the subject line. The subject should > summarize your changes and "add ..NONEG" is just one part of it. The > other is "convert to use ...NONEG". So I suggest "parse-options: > convert to use new macro OPT_SET_INT_NONEG()" or something like that. > > You should also explain in the message body (before Signed-off-by:) > why this is a good thing to do. My guess is better readability and > harder to make mistakes in the future when you have to declare new > options with noneg.
As I said elsewhere, I am not sure if doubling the number of OPT_<type> macros as your micro suggestion proposes is the right solution to the problem.
What are we trying to solve?