Re: [PATCH v5 01/14] bulk-checkin: rename 'state' variable and separate 'plugged' boolean
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 30, 2022, 20:24 UTC
- Message-ID
- <xmqqr16j6ve3.fsf@gitster.g>
- In-Reply-To
- <CANQDOdfWTufEn0NRSAOG991JcS4x8GsCC62UCLUTEc3gD6tfGA@mail.gmail.com>
Neeraj Singh <nksingh85@gmail.com> writes:
Show 9 quoted lines
>> We should add a new function, flush_bulk_checking_packfile(), to >> flush only the packfile part of the bulk_checkin_state without >> affecting other things---the "plugged" bit is the only one in the >> current code before this series, but it does not have to stay to be >> so > > I'm happy to rename the packfile related stuff to end with _packfile > to make it clear that all of that state and functionality is related > to batching of packfile additions.
I do not care about names, though. If you took that I hinted any such change, sorry about that. _state is fine as-is.
I do care about not ejecting plugged out of the structure and instead keeping them together, with proper way to flush the part that deflate_to_pack() wants to flush, instead of abusing the "finish".
Thanks.