Re: [PATCH] send-pack: use internal argv_array of struct child_process
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 22, 2017, 20:11 UTC
- Message-ID
- <xmqqpo76r09w.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <CAGZ79kb43_nSm-tjv3zOw7OFzByM3WocYboB6QRr=Z7bRue_hA@mail.gmail.com>
Stefan Beller <sbeller@google.com> writes:
Show 8 quoted lines
>> + argv_array_push(&po.args, "pack-objects"); >> + argv_array_push(&po.args, "--all-progress-implied"); >> + argv_array_push(&po.args, "--revs"); >> + argv_array_push(&po.args, "--stdout"); > > (useless nit of the day, no need to resend:) > These four statements could be done as pushl(a,b,c, NULL); > but it would not differ in readability, so I guess either is fine.
Yup. Shorter is not necessarily better. If we anticipate that we will need to update the set of options later (and I suspect we may be doing so soon, given what JeffH and JTan are working on recently), one option (or option-argument pair) per line is a more preferrable form from the maintenance point of view.