From: Junio C Hamano Date: Fri, 22 Dec 2017 20:11:07 GMT Subject: Re: [PATCH] send-pack: use internal argv_array of struct child_process Message-ID: In-Reply-To: Stefan Beller writes: >> + argv_array_push(&po.args, "pack-objects"); >> + argv_array_push(&po.args, "--all-progress-implied"); >> + argv_array_push(&po.args, "--revs"); >> + argv_array_push(&po.args, "--stdout"); > > (useless nit of the day, no need to resend:) > These four statements could be done as pushl(a,b,c, NULL); > but it would not differ in readability, so I guess either is fine. Yup. Shorter is not necessarily better. If we anticipate that we will need to update the set of options later (and I suspect we may be doing so soon, given what JeffH and JTan are working on recently), one option (or option-argument pair) per line is a more preferrable form from the maintenance point of view.