Re: [PATCH v7 2/4] notes.c: cleanup for "designated init"
Teng Long <dyroneteng@gmail.com> writes:
> From: Teng Long <dyroneteng@gmail.com>
>
> The "struct note_data d = { 0, 0, NULL, STRBUF_INIT };" style could be
> replaced with designated init format.I think our codebase calls it "designated initializer".
notes.c: use designated initializers for clarity
The "struct note_data d = { 0, 0, NULL, STRBUF_INIT };" style could be
replaced with designated initializer for clarity.
Signed-off-by: Teng Long <dyroneteng@gmail.com>
Signed-off-by: Junio C Hamano <gitster@pobox.com>