From: Junio C Hamano Date: Wed, 29 Mar 2023 22:17:29 GMT Subject: Re: [PATCH v7 2/4] notes.c: cleanup for "designated init" Message-ID: In-Reply-To: <9dc123c8f7a1cc2e7a146fb336939d6076369e2e.1680012650.git.dyroneteng@gmail.com> Teng Long writes: > From: Teng Long > > The "struct note_data d = { 0, 0, NULL, STRBUF_INIT };" style could be > replaced with designated init format. I think our codebase calls it "designated initializer". notes.c: use designated initializers for clarity The "struct note_data d = { 0, 0, NULL, STRBUF_INIT };" style could be replaced with designated initializer for clarity. Signed-off-by: Teng Long Signed-off-by: Junio C Hamano