Re: [PATCH v6 2/4] advice: change "setupStreamFailure" to "setUpstreamFailure"
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 27, 2020, 17:38 UTC
- Message-ID
- <xmqqo8tkexru.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <828b4aee19d09218beca6ad1d93006012be99a0a.1582778112.git.gitgitgadget@gmail.com>
"Heba Waly via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 21 quoted lines
> From: Heba Waly <heba.waly@gmail.com>
>
> fb6fbffbda (advice: keep config name in camelCase in advice_config[],
> 2018-05-26) changed the config names to camelCase, but one of the names
> wasn't changed correctly. Fix it.
>
> Signed-off-by: Heba Waly <heba.waly@gmail.com>
> ---
> advice.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/advice.c b/advice.c
> index fd836332dad..258cc9ba7af 100644
> --- a/advice.c
> +++ b/advice.c
> @@ -80,7 +80,7 @@ static struct {
> { "sequencerInUse", &advice_sequencer_in_use },
> { "implicitIdentity", &advice_implicit_identity },
> { "detachedHead", &advice_detached_head },
> - { "setupStreamFailure", &advice_set_upstream_failure },
> + { "setUpstreamFailure", &advice_set_upstream_failure },The mistake is sort-of understandable, when "setup" is taken as a verb. Well spotted ;-)
> { "objectNameWarning", &advice_object_name_warning },
> { "amWorkDir", &advice_amworkdir },
> { "rmHints", &advice_rm_hints },