Re: [PATCH v3 2/3] t/: port helper/test-sha1.c to unit-tests/t-hash.c
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 24, 2024, 15:49 UTC
- Message-ID
- <xmqqo78vnrba.fsf@gitster.g>
- In-Reply-To
- <CAP8UFD1=yjZEZWvMYKq1RyY8fMSHze4XcLbCZMSFhCLBheaM+w@mail.gmail.com>
Christian Couder <christian.couder@gmail.com> writes:
Show 7 quoted lines
>> Can we refactor this test to stop doing that? E.g., would it work if we >> used git-hash-object(1) to check that SHA1DC does its thing? Then we >> could get rid of the helper altogether, as far as I understand. > > It could perhaps work if we used git-hash-object(1) instead of > `test-tool sha1` in t0013-sha1dc to check that SHA1DC does its thing, > but we could do that in a separate patch or patch series.
Yeah, I think such a plan to make preliminary refactoring as a separate series, and then have another series to get rid of "test-tool sha1" (and "test-tool sha256" as well?) on top of it would work well.
Show 6 quoted lines
>> > + if (!check(!!data)) {
>>
>> Is this double negation needed? Can't we just `if (!check(data))`?
>
> As far as I remember it is needed as check() is expecting an 'int'
> while 'data' is a 'void *'.It might be easier to read by being more explicit, "data != NULL", if that is the case? check() is like assert(), i.e., "we expect data is not NULL", and if (!check("expected condition")) { guards an error handling block for the case in which the expectation is not met, right?