git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/8] t5512: generate references with generate_references()

From
Junio C Hamano <gitster@pobox.com>
Date
Mar 25, 2020, 06:41 UTC
Message-ID
<xmqqmu85x7fo.fsf@gitster.c.googlers.com>
In-Reply-To
<674de50db28a50554d7af6e5c869c427d06f78aa.1585115341.git.liu.denton@gmail.com>
Denton Liu <liu.denton@gmail.com> writes:
> +generate_references () {
> +	for i

Is it just me who thinks variables used in iteration should be called i, j, etc. only when they are integers?

Show 20 quoted lines
> +	do
> +		oid=$(git rev-parse "$i") || return 1
> +		printf '%s\t%s\n' "$oid" "$i"
> +	done
> +}
> +
>  test_expect_success setup '
>  	>file &&
>  	git add file &&
> @@ -43,34 +51,19 @@ test_expect_success 'ls-remote self' '
>  '
>  
>  test_expect_success 'ls-remote --sort="version:refname" --tags self' '
> -	cat >expect <<-EOF &&
> -	$(git rev-parse mark)	refs/tags/mark
> -	$(git rev-parse mark1.1)	refs/tags/mark1.1
> -	$(git rev-parse mark1.2)	refs/tags/mark1.2
> -	$(git rev-parse mark1.10)	refs/tags/mark1.10
> -	EOF
> +	generate_references refs/tags/mark refs/tags/mark1.1 refs/tags/mark1.2 refs/tags/mark1.10 >expect &&
Hmph, can we avoid overlong lines like this one?
	generate_references >expect <<-EOF
	refs/tags/mark
	refs/tags/mark1.1
	refs/tags/mark1.2
	refs/tags/mark1.10
	EOF

i.e. teaching the helper function to read from its standard input stream, may make it more readable (i.e. it is more obvious what the order of expected output lines are, as you are listing them one by one on a line of its own).

Previous: Eric SunshineNext: Denton Liu
Message 6 of 30 in “t: replace incorrect test_must_fail usage (part 3)”
  1. 0/8 t: replace incorrect test_must_fail usage (part 3)Denton Liu, Mar 25, 2020
  2. 1/8 t5512: don't use `test_must_fail test_cmp`Denton Liu, Mar 25, 2020
  3. 3/8 t5512: stop losing return codes of git commandsDenton Liu, Mar 25, 2020
  4. 2/8 t5512: generate references with generate_references()Denton Liu, Mar 25, 2020
  5. Eric SunshineMar 25, 2020
  6. Junio C HamanoMar 25, 2020
  7. 5/8 t5607: reorder `nongit test_must_fail`Denton Liu, Mar 25, 2020
  8. 4/8 t5550: remove use of `test_might_fail grep`Denton Liu, Mar 25, 2020
  9. Junio C HamanoMar 25, 2020
  10. 8/8 t5801: teach compare_refs() to accept !Denton Liu, Mar 25, 2020
  11. Junio C HamanoMar 25, 2020
  12. Eric SunshineMar 25, 2020
  13. 7/8 t5612: stop losing return codes of git commandsDenton Liu, Mar 25, 2020
  14. 6/8 t5612: don't use `test_must_fail test_cmp`Denton Liu, Mar 25, 2020
  15. Junio C HamanoMar 25, 2020
  16. 0/8 t: replace incorrect test_must_fail usage (part 3)Denton Liu, Mar 26, 2020
  17. 1/8 t5512: don't use `test_must_fail test_cmp`Denton Liu, Mar 26, 2020
  18. 2/8 t5512: stop losing git exit code in here-docsDenton Liu, Mar 26, 2020
  19. Eric SunshineMar 26, 2020
  20. 3/8 t5512: stop losing return codes of git commandsDenton Liu, Mar 26, 2020
  21. 4/8 t5550: simplify no matching line checkDenton Liu, Mar 26, 2020
  22. Eric SunshineMar 26, 2020
  23. 5/8 t5607: reorder `nongit test_must_fail`Denton Liu, Mar 26, 2020
  24. 6/8 t5612: don't use `test_must_fail test_cmp`Denton Liu, Mar 26, 2020
  25. 7/8 t5612: stop losing return codes of git commandsDenton Liu, Mar 26, 2020
  26. 8/8 t5801: teach compare_refs() to accept !Denton Liu, Mar 26, 2020
  27. 9/9 fixup! t5512: stop losing git exit code in here-docsDenton Liu, Mar 27, 2020
  28. Junio C HamanoMar 27, 2020
  29. Eric SunshineMar 27, 2020
  30. Junio C HamanoMar 27, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.