Re: [PATCH v3] sideband.c: remove redundant 'NEEDSWORK' tag
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 27, 2023, 22:22 UTC
- Message-ID
- <xmqqmstvl1z8.fsf@gitster.g>
- In-Reply-To
- <pull.1625.v3.git.1703672407895.gitgitgadget@gmail.com>
"Chandra Pratap via GitGitGadget" <gitgitgadget@gmail.com> writes:
> - * NEEDSWORK: use "size_t n" instead for clarity. > ++ * It is fine to use "int n" here instead of "size_t n" as all calls to this > ++ * function pass an 'int' parameter.
This does not sound like a sufficient justification, though.
We should also explain why "int" is good enough for these callers. Otherwise, using size_t throughout the callchain would become another viable solution.