Re: [PATCH v3 12/24] cache-tree: share code between functions writing an index as a tree
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 16, 2019, 22:01 UTC
- Message-ID
- <xmqqlfvszs5n.fsf@gitster-ct.c.googlers.com>
- In-Reply-To
- <20190815214053.16594-13-newren@gmail.com>
Elijah Newren <newren@gmail.com> writes:
Show 9 quoted lines
> write_tree_from_memory() appeared to be a merge-recursive special that > basically duplicated write_index_as_tree(). The two have a different > signature, but the bigger difference was just that write_index_as_tree() > would always unconditionally read the index off of disk instead of > working on the current in-memory index. So: > > * split out common code into write_index_as_tree_internal() > > * rename write_tree_from_memory() to write_inmemory_index_as_tree(),
Somewhat minor, but I find "inmemory_index" hard to see while scanning the patch. Perhaps call it "in_core_index" instead?
I originally started the above with "Very minor, ...", but as this is exposed to the public in a header file, the name matters a bit more than that.