Re: [PATCH 13/16] init: allow alternate backends to be set for new repos
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 5, 2016, 18:03 UTC
- Message-ID
- <xmqqk2nnkio4.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <1452014787.3892.40.camel@twopensource.com>
David Turner <dturner@twopensource.com> writes:
Show 5 quoted lines
> I'm working on the rest now, but wanted to comment on this first. I > went ahead and made this change, but I'm not sure I like it. In the > git codebase, the concept will continue to be called "backend"; there > are already-accepted patches using that terminology. Having two > separate names for the same thing seems confusing to me.
We have the option to update whatever "are already-accepted" [*1*]. That would allow us to uniformly call it "ref storage", if we wanted to.
In any case, we shouldn't be using an unqualified "backend" (or "storage" for that matter); we should always say "ref", i.e. either "ref backend" or "ref storage", in the name.
Between "backend" and "storage", I am slightly in favor of the latter, but I am not good at naming things so...
[Footnote]
*1* Output from
$ git grep backend master --
seems to show me only
master:refs.c: * The backend-independent part of the reference module.
and all others are other kinds of backends, e.g. "merge backend", "http-backend", etc. so that may not be too bad.