Re: [PATCH 13/16] init: allow alternate backends to be set for new repos
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- Jan 6, 2016, 12:02 UTC
- Message-ID
- <568D0267.7080707@alum.mit.edu>
- In-Reply-To
- <xmqqk2nnkio4.fsf@gitster.mtv.corp.google.com>
On 01/05/2016 07:03 PM, Junio C Hamano wrote:
Show 11 quoted lines
> David Turner <dturner@twopensource.com> writes: > >> I'm working on the rest now, but wanted to comment on this first. I >> went ahead and made this change, but I'm not sure I like it. In the >> git codebase, the concept will continue to be called "backend"; there >> are already-accepted patches using that terminology. Having two >> separate names for the same thing seems confusing to me. > > We have the option to update whatever "are already-accepted" [*1*]. > That would allow us to uniformly call it "ref storage", if we wanted > to.
...whereas whatever we name the option, we have to live with forever because it is user-facing. It's more important to get the option name correct (though I agree that it would be nice for the nomenclature used in the code to be reminiscent of the option name).
Michael
-- Michael Haggerty mhagger@alum.mit.edu