Re: [PATCH] CI: add SANITIZE=[address|undefined] jobs
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jul 27, 2022, 14:30 UTC
- Message-ID
- <xmqqilnityp0.fsf@gitster.g>
- In-Reply-To
- <d4dcb1f6-6076-3725-d479-7e9f1fece2a3@github.com>
Derrick Stolee <derrickstolee@github.com> writes:
Show 28 quoted lines
>> - jobname: linux-leaks >> cc: gcc >> pool: ubuntu-latest >> + - jobname: SANITIZE=address >> + cc: gcc >> + pool: ubuntu-latest >> + - jobname: SANITIZE=undefined >> + cc: gcc >> + pool: ubuntu-latest > >> @@ -277,6 +277,12 @@ linux-leaks) >> export SANITIZE=leak >> export GIT_TEST_PASSING_SANITIZE_LEAK=true >> ;; >> +SANITIZE=address) >> + export SANITIZE=address >> + ;; >> +SANITIZE=undefined) >> + export SANITIZE=undefined >> + ;; > > In both of these cases, we are breaking from the nearby pattern. These > jobs could be renamed to linux-address and linux-undefined to match the > linux-leaks job. > > Alternatively, we could rename linux-leaks to SANITIZE=leak, since the > point is not to test the Linux platform but to use the additional runtime > checks (and Linux is the fasted CI platform).
I tend to agree that in the existing linux-leaks job, the "linux"-ness is much less important than the "leaks"-ness, so the "alternative" might be slightly more preferable, but I do not mind the renaming goes the other way, either.
Thanks for your good eyes and good taste.