From: Junio C Hamano Date: Wed, 27 Jul 2022 14:30:51 GMT Subject: Re: [PATCH] CI: add SANITIZE=[address|undefined] jobs Message-ID: In-Reply-To: Derrick Stolee writes: >> - jobname: linux-leaks >> cc: gcc >> pool: ubuntu-latest >> + - jobname: SANITIZE=address >> + cc: gcc >> + pool: ubuntu-latest >> + - jobname: SANITIZE=undefined >> + cc: gcc >> + pool: ubuntu-latest > >> @@ -277,6 +277,12 @@ linux-leaks) >> export SANITIZE=leak >> export GIT_TEST_PASSING_SANITIZE_LEAK=true >> ;; >> +SANITIZE=address) >> + export SANITIZE=address >> + ;; >> +SANITIZE=undefined) >> + export SANITIZE=undefined >> + ;; > > In both of these cases, we are breaking from the nearby pattern. These > jobs could be renamed to linux-address and linux-undefined to match the > linux-leaks job. > > Alternatively, we could rename linux-leaks to SANITIZE=leak, since the > point is not to test the Linux platform but to use the additional runtime > checks (and Linux is the fasted CI platform). I tend to agree that in the existing linux-leaks job, the "linux"-ness is much less important than the "leaks"-ness, so the "alternative" might be slightly more preferable, but I do not mind the renaming goes the other way, either. Thanks for your good eyes and good taste.