Re: What's cooking in git.git (Nov 2016, #04; Mon, 21)
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Nov 21, 2016, 23:14 UTC
- Message-ID
- <xmqqh970h1da.fsf@gitster.mtv.corp.google.com>
- In-Reply-To
- <CAGZ79kbCebHojPDUdHn2mmjUwRe-FOcnJqtoa828PJwC6P5mNw@mail.gmail.com>
Stefan Beller <sbeller@google.com> writes:
Show 13 quoted lines
>> * bw/grep-recurse-submodules (2016-11-18) 6 commits >> - grep: search history of moved submodules >> - grep: enable recurse-submodules to work on <tree> objects >> - grep: optionally recurse into submodules >> - grep: add submodules as a grep source type >> - submodules: load gitmodules file from commit sha1 >> - submodules: add helper functions to determine presence of submodules >> >> "git grep" learns to optionally recurse into submodules >> >> Waiting for review. > > I did review both off and on list and I think the latest version is good.
I thought that there were strange mixups of two enumeration types that are incompatible, at least. Is there an update that I didn't see, or you didn't read problems pointed out on list?
Show 17 quoted lines
>> * jt/use-trailer-api-in-commands (2016-11-02) 6 commits >> - sequencer: use trailer's trailer layout >> - trailer: have function to describe trailer layout >> - trailer: avoid unnecessary splitting on lines >> - commit: make ignore_non_trailer take buf/len >> - SQUASH??? >> - trailer: be stricter in parsing separators >> >> Commands that operate on a log message and add lines to the trailer >> blocks, such as "format-patch -s", "cherry-pick (-x|-s)", and >> "commit -s", have been taught to use the logic of and share the >> code with "git interpret-trailer". >> >> What's the doneness of this topic? > > From a cursory read (with the SQUASH applied) > this seems to be done to me.
We are not all that in a hurry to move non-fix to 'next' only with a cursory read at this point in the cycle ;-).
Show 10 quoted lines
>> * sb/submodule-config-cleanup (2016-11-02) 3 commits
>> - submodule-config: clarify parsing of null_sha1 element
>> - submodule-config: rename commit_sha1 to commit_or_tree
>> - submodule config: inline config_from_{name, path}
>>
>> What's the doneness of this topic?
>
> Jake Keller reviewed this and it turns out I was not careful in patch 2/3.
>
> Will resend.OK. Thanks.