git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/5] parse_branchname_arg(): introduce expect_commit_only

From
Junio C Hamano <gitster@pobox.com>
Date
Dec 18, 2019, 19:18 UTC
Message-ID
<xmqqfthhe92v.fsf@gitster-ct.c.googlers.com>
In-Reply-To
<a84633a44474aa25bd1101a9ca2a5d9687900bf2.1574969538.git.gitgitgadget@gmail.com>

"Alexandr Miloslavskiy via GitGitGadget" <gitgitgadget@gmail.com> writes:

> From: Alexandr Miloslavskiy <alexandr.miloslavskiy@syntevo.com>
>
> `has_dash_dash` unexpectedly takes `opts->accept_pathspec` into account.

You also touched the code that depends on opts->accept_pathspec in the earlier step 1/5; these two steps seem harder to reason about than necessary---I wonder if it is easier to explain and understand if these two steps are merged into one and explained together?

Show 20 quoted lines
> diff --git a/builtin/checkout.c b/builtin/checkout.c
> index 655b389756..5c6131dbe6 100644
> --- a/builtin/checkout.c
> +++ b/builtin/checkout.c
> @@ -1123,7 +1123,7 @@ static int parse_branchname_arg(int argc, const char **argv,
>  	const char **new_branch = &opts->new_branch;
>  	const char *arg;
>  	int dash_dash_pos;
> -	int has_dash_dash = 0;
> +	int has_dash_dash = 0, expect_commit_only = 0;
>  	int i;
>  
>  	/*
> @@ -1194,7 +1194,10 @@ static int parse_branchname_arg(int argc, const char **argv,
>  		    die(_("only one reference expected, %d given."), dash_dash_pos);
>  	}
>  
> -	opts->count_checkout_paths = !opts->quiet && !has_dash_dash;
> +	if (has_dash_dash)
> +	    expect_commit_only = 1;
Non-standard indentation here.
> +	opts->count_checkout_paths = !opts->quiet && !expect_commit_only;

OK. count_checkout_paths is relevant only when checking out paths out of a tree-ish, so "expect-commit-only" would be false in such a situation. On the other hand, if we were checking out a branch (or detaching), we must have a commit and a tree-ish is insufficient, so expect_commit_only would be true in such a case.

Makes sense. I am wondering if we still need has_dash_dash, and also if expect_commit_only is the best name for the variable.

Thanks.
Show 31 quoted lines
> @@ -1210,10 +1213,10 @@ static int parse_branchname_arg(int argc, const char **argv,
>  		 */
>  		int recover_with_dwim = dwim_new_local_branch_ok;
>  
> -		int could_be_checkout_paths = !has_dash_dash &&
> +		int could_be_checkout_paths = !expect_commit_only &&
>  			check_filename(opts->prefix, arg);
>  
> -		if (!has_dash_dash && !no_wildcard(arg))
> +		if (!expect_commit_only && !no_wildcard(arg))
>  			recover_with_dwim = 0;
>  
>  		/*
> @@ -1242,7 +1245,7 @@ static int parse_branchname_arg(int argc, const char **argv,
>  		}
>  
>  		if (!recover_with_dwim) {
> -			if (has_dash_dash)
> +			if (expect_commit_only)
>  				die(_("invalid reference: %s"), arg);
>  			return 0;
>  		}
> @@ -1253,7 +1256,7 @@ static int parse_branchname_arg(int argc, const char **argv,
>  	if (!opts->source_tree)                   /* case (1): want a tree */
>  		die(_("reference is not a tree: %s"), arg);
>  
> -	if (!has_dash_dash) {	/* case (3).(d) -> (1) */
> +	if (!expect_commit_only) {	/* case (3).(d) -> (1) */
>  		/*
>  		 * Do not complain the most common case
>  		 *	git checkout branch
Previous: Alexandr Miloslavskiy via GitGitGadgetNext: Alexandr Miloslavskiy
Message 6 of 10 in “parse_branchname_arg(): make code easier to understand”
  1. 0/5 parse_branchname_arg(): make code easier to understandAlexandr Miloslavskiy via GitGitGadget, Nov 28, 2019
  2. 1/5 parse_branchname_arg(): fix dash_dash_pos, drop argcountAlexandr Miloslavskiy via GitGitGadget, Nov 28, 2019
  3. Junio C HamanoDec 18, 2019
  4. Alexandr MiloslavskiyDec 19, 2019
  5. 2/5 parse_branchname_arg(): introduce expect_commit_onlyAlexandr Miloslavskiy via GitGitGadget, Nov 28, 2019
  6. Junio C HamanoDec 18, 2019
  7. Alexandr MiloslavskiyDec 19, 2019
  8. 5/5 t2024: cover more casesAlexandr Miloslavskiy via GitGitGadget, Nov 28, 2019
  9. 4/5 parse_branchname_arg(): refactor the decision makingAlexandr Miloslavskiy via GitGitGadget, Nov 28, 2019
  10. 3/5 parse_branchname_arg(): update code commentsAlexandr Miloslavskiy via GitGitGadget, Nov 28, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.