git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] http-backend: remove a duplicated code branch

From
Junio C Hamano <gitster@pobox.com>
Date
Oct 12, 2021, 17:15 UTC
Message-ID
<xmqqfst65fmn.fsf@gitster.g>
In-Reply-To
<YWTyr6joJlyi1TPe@coredump.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 28 quoted lines
>> diff --git a/http-backend.c b/http-backend.c
>> index e7c0eeab23..3d6e2ff17f 100644
>> --- a/http-backend.c
>> +++ b/http-backend.c
>> @@ -466,9 +466,7 @@ static void run_service(const char **argv, int buffer_input)
>>  	struct child_process cld = CHILD_PROCESS_INIT;
>>  	ssize_t req_len = get_content_length();
>>  
>> -	if (encoding && !strcmp(encoding, "gzip"))
>> -		gzipped_request = 1;
>> -	else if (encoding && !strcmp(encoding, "x-gzip"))
>> +	if (encoding && (!strcmp(encoding, "gzip") || !strcmp(encoding, "x-gzip")))
>>  		gzipped_request = 1;
>
> I think this conversion is correct, and I do find the resulting slightly
> easier to read. I wondered if the two conditions might have come
> separately, but no, they were both there in the initial 556cfa3b6d
> (Smart fetch and push over HTTP: server side, 2009-10-30).
>
> We do frown a bit on making small style changes like this. This kind of
> churn isn't dramatically improving the quality of the code, and it
> carries the risk of regression (if there is something subtle that you or
> the reviewers missed) and creates a maintenance burden (it may conflict
> with other patches, though I doubt it in this case, and it creates work
> for reviewers and the maintainer to apply).
>
> So...I dunno. I don't mind it, but it is not a pattern we like to
> encourage in general. Let's see what Junio thinks.

This particular conversion is mostly "Meh", although if it were done in this way:

	if (encoding) {
		if (!strcmp(encoding, "gzip") || !strcmp(encoding, "x-gzip"))
			gzipped_request = 1;
	}

the result may be a bit less "meh" by making it easier to adjust the code for other kinds of encoding in the future.

My usual rule of thumb for such a single-hunk clean-up patch that is "obviously not incorrect" is to take it only once or twice per new contributor. At some point, new contributors gain enough experience to know better, at which point I'd start frowning at them.

Thanks.
Previous: Junio C HamanoNext: Robin Dupret
Message 6 of 9 in “http-backend: remove a duplicated code branch”
  1. http-backend: remove a duplicated code branchRobin Dupret, Oct 11, 2021
  2. http-backend: remove a duplicated code branchRobin Dupret, Oct 11, 2021
  3. Jeff KingOct 12, 2021
  4. Ævar Arnfjörð BjarmasonOct 12, 2021
  5. Junio C HamanoOct 12, 2021
  6. Junio C HamanoOct 12, 2021
  7. http-backend: remove a duplicated code branchRobin Dupret, Oct 24, 2021
  8. Junio C HamanoOct 25, 2021
  9. Robin DupretOct 26, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.