git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] doc: fill in omitted word

From
Junio C Hamano <gitster@pobox.com>
Date
Nov 10, 2016, 22:07 UTC
Message-ID
<xmqqd1i356ql.fsf@gitster.mtv.corp.google.com>
In-Reply-To
<20161104214357.32477-1-kristoffer.haugsbakk@gmail.com>
Kristoffer Haugsbakk <kristoffer.haugsbakk@gmail.com> writes:
Show 15 quoted lines
> Signed-off-by: Kristoffer Haugsbakk <kristoffer.haugsbakk@gmail.com>
> ---
>  Documentation/gitcore-tutorial.txt | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/Documentation/gitcore-tutorial.txt b/Documentation/gitcore-tutorial.txt
> index 4546fa0..9860517 100644
> --- a/Documentation/gitcore-tutorial.txt
> +++ b/Documentation/gitcore-tutorial.txt
> @@ -25,7 +25,7 @@ you want to understand Git's internals.
>  The core Git is often called "plumbing", with the prettier user
>  interfaces on top of it called "porcelain". You may not want to use the
>  plumbing directly very often, but it can be good to know what the
> -plumbing does for when the porcelain isn't flushing.
> +plumbing does for you when the porcelain isn't flushing.

I need an English teacher here to help me out, but I think this changes the meaning of the sentence from what the original author intended..

The way I've read this statement for the past ten years since it was written originally at 8c7fa2478e ("Add first cut at a simple git tutorial.", 2005-05-31) and then slightly reworded at f35ca9ed3e ("tutorial.txt: start describing how to copy repositories", 2005-06-01) is that

 * there are unfortunate occasions in which the porcelain is not
   flushing, and 
 * the knowledge of what the plumbing does is a good thing to have
   for such occasions.  It will help you figure out what needs to be
   done.
The rewritten text means a very different thing, at least to me.
 * there are things plumbing does for you.
 * the knowledge of what they are helps when the porcelain isn't
   flushing.

Just dropping "for" instead of adding "you" may make it easier to read, grammatically more correct and retain the original intent better, I suspect.

Previous: Kristoffer HaugsbakkNext: Jeff King
Message 2 of 4 in “doc: fill in omitted word”
  1. doc: fill in omitted wordKristoffer Haugsbakk, Nov 4, 2016
  2. Junio C HamanoNov 10, 2016
  3. Jeff KingNov 10, 2016
  4. Kristoffer HaugsbakkDec 9, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.