Re: [PATCH 4/4] checkout: cleanup --conflict=<style> parsing
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 11, 2024, 17:41 UTC
- Message-ID
- <xmqqcys0sm22.fsf@gitster.g>
- In-Reply-To
- <f0c88900-63d3-46ed-9cb8-fc7c3fc07c28@gmail.com>
phillip.wood123@gmail.com writes:
Show 10 quoted lines
> On 08/03/2024 16:15, Junio C Hamano wrote: >> "Phillip Wood via GitGitGadget" <gitgitgadget@gmail.com> writes: >> parse_conflict_style_name() that takes a name and returns >> conflict_style enumeration constant would not risk such a confusion, >> I guess. > > Can I just check if you mean that we should convert XDL_MERGE_DIFF3 > and friends to be an enum, or are you happy to leave them as > pre-processor constants and have parse_conflict_style_name() return an > int?
The latter. I was only wondering what the good name for the new function was and did not mean to imply that we want conversions from C preprocessor macros to enums.