Re: [PATCH 7/7] Do not use curl_easy_strerror with curl < 7.12.0
Jeff King <peff@peff.net> writes:
Show 18 quoted lines
> On Wed, Apr 05, 2017 at 03:04:24PM +0200, Tom G. Christensen wrote:
> ...
> These kinds of interleaved conditionals make me nervous that we'll get
> something wrong (especially without braces, it's not immediately clear
> that both sides are a single statement).
>
> I wonder if it would be more readable to do something like:
>
> #if LIBCURL_VERSION_NUM < 0x070c00
> static const char *curl_easy_strerror(CURL *curl)
> {
> return "[error code unavailable; curl version too old]";
> }
> #endif
>
> Then callers don't have to individually deal with the ifdef. It does
> mean that the user sees that kind-of ugly message, but maybe that is a
> good thing. They know they need to upgrade curl to see more details.Yup, thanks for a very good suggestion.