git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Improve function dir.c:trim_trailing_spaces()

From
Junio C Hamano <gitster@pobox.com>
Date
May 30, 2014, 18:45 UTC
Message-ID
<xmqqa99z9kbz.fsf@gitster.dls.corp.google.com>
In-Reply-To
<20140530020444.GH28683@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
Show 13 quoted lines
> On Thu, May 29, 2014 at 02:34:33PM -0700, Pasha Bolokhov wrote:
>
>> > However, I doubt it makes that much of a difference in practice, so
>> > unless it's measurable, I would certainly go with the version that is
>> > more readable (and correct, of course).
>> 
>>     Sorry, just to recap, you would go with the existing version
>> (which needs correction), or with the one that is being suggested? (I
>> agree I can format the style a tiny bit better in the latter one)
>
> I actually think the original left-to-right is a little easier to
> follow, but I do not feel strongly. I mainly meant "argue based on
> readability and correctness, do not argue based on speed".
Sensible.
> I'd be OK with either, though I have a slight preference for the first,
> just because I find the "bslash ^= 1" bit of yours, while clever, a bit
> hard to follow.
FWIW, I think I agree.
Previous: Jeff King
Message 5 of 5 in “Improve function dir.c:trim_trailing_spaces()”
  1. Improve function dir.c:trim_trailing_spaces()Pasha Bolokhov, May 28, 2014
  2. Jeff KingMay 29, 2014
  3. Pasha BolokhovMay 29, 2014
  4. Jeff KingMay 30, 2014
  5. Junio C HamanoMay 30, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.