git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/6] quote_path: give flags parameter to quote_path()

From
Junio C Hamano <gitster@pobox.com>
Date
Sep 10, 2020, 15:17 UTC
Message-ID
<xmqq7dt1r78z.fsf@gitster.c.googlers.com>
In-Reply-To
<xmqqo8mdr7ve.fsf@gitster.c.googlers.com>
Junio C Hamano <gitster@pobox.com> writes:
Show 8 quoted lines
> Of course none of the above becomes unnecessary if we scan the whole
> string for SP before the main loop in quote-c-style-counted, but the
> function was written to process the input in a single pass and such
> a change defeats its design.  If we need to do it in two passes, we
> can have the caller do so anyway, at least for now.  That thinking
> lead to the final organization of the series, with two steps that
> used to be preparatory for passing the flag down thru to the bottom
> layer rebased out as a discardable appendix at the end.

Actually, this made me realize that another variant is possible. It might be easier to read, or it might not. Since I cannot tell without actually writing one, let's see ...

Instead of scanning the output from quote-c-style-counted for SP in the caller, the caller can do something like this.

/* quote path as relative to the given prefix */
char *quote_path(const char *in, const char *prefix, struct strbuf *out, unsigned flags)
{
	struct strbuf sb = STRBUF_INIT;
	const char *rel = relative_path(in, prefix, &sb);
	int add_dq_ourselves = !!(flags & QUOTE_PATH_QUOTE_SP) && !!strchr(rel, ' ');
	strbuf_reset(out);
        if (add_dq_ourselves)
        	strbuf_addch(out, '"');
	quote_c_style_counted(rel, strlen(rel), out, NULL,
        		      add_dq_ourselves ? CQUOTE_NODQ : 0);
        if (add_dq_ourselves)
        	strbuf_addch(out, '"');
	strbuf_release(&sb);
	return out->buf;
}

That is, we tell quote-c-style-counted not to put dq-pair around its output whether it needs to do the backslash quoting, if we know we want the result inside dq-pair anyway (iow, when the caller wants us to treat SP specially and we do see SP in the input).

I don't know if this is easier to follow or not. I do think so right now but that is only because it is still fresh in my brain.

Previous: Junio C HamanoNext: Jeff King
Message 17 of 41 in “[Bug report] git status doesn't escape paths of untracked files”
  1. Patrick FongSep 8, 2020
  2. Junio C HamanoSep 8, 2020
  3. brian m. carlsonSep 8, 2020
  4. Junio C HamanoSep 8, 2020
  5. Junio C HamanoSep 8, 2020
  6. Junio C HamanoSep 8, 2020
  7. Martin ÅgrenSep 8, 2020
  8. René ScharfeSep 8, 2020
  9. Junio C HamanoSep 9, 2020
  10. René ScharfeSep 10, 2020
  11. Junio C HamanoSep 10, 2020
  12. wt-status: quote paths identically whether tracked or untrackedbrian m. carlson, Sep 8, 2020
  13. 0/6 quote_path() clean-upsJunio C Hamano, Sep 8, 2020
  14. 2/6 quote_path: give flags parameter to quote_path()Junio C Hamano, Sep 8, 2020
  15. Jeff KingSep 10, 2020
  16. Junio C HamanoSep 10, 2020
  17. Junio C HamanoSep 10, 2020
  18. Jeff KingSep 10, 2020
  19. 3/6 quote_path: optionally allow quoting a path with SP in itJunio C Hamano, Sep 8, 2020
  20. Jeff KingSep 10, 2020
  21. 4/6 wt-status: consistently quote paths in "status --short" outputJunio C Hamano, Sep 8, 2020
  22. 1/6 quote_path: rename quote_path_relative() to quote_path()Junio C Hamano, Sep 8, 2020
  23. 6/6 quote: turn 'nodq' parameter into a set of flagsJunio C Hamano, Sep 8, 2020
  24. Jeff KingSep 10, 2020
  25. 5/6 quote: rename misnamed sq_lookup[] to cq_lookup[]Junio C Hamano, Sep 8, 2020
  26. Chris TorekSep 8, 2020
  27. Jeff KingSep 10, 2020
  28. 0/7 quote_path() clean-upsJunio C Hamano, Sep 10, 2020
  29. 1/7 quote_path: rename quote_path_relative() to quote_path()Junio C Hamano, Sep 10, 2020
  30. 4/7 quote_path: code clarificationJunio C Hamano, Sep 10, 2020
  31. Jeff KingSep 10, 2020
  32. Junio C HamanoSep 10, 2020
  33. Jeff KingSep 10, 2020
  34. 7/7 quote: turn 'nodq' parameter into a set of flagsJunio C Hamano, Sep 10, 2020
  35. 5/7 wt-status: consistently quote paths in "status --short" outputJunio C Hamano, Sep 10, 2020
  36. Jeff KingSep 10, 2020
  37. Junio C HamanoSep 10, 2020
  38. 2/7 quote_path: give flags parameter to quote_path()Junio C Hamano, Sep 10, 2020
  39. 3/7 quote_path: optionally allow quoting a path with SP in itJunio C Hamano, Sep 10, 2020
  40. 6/7 quote: rename misnamed sq_lookup[] to cq_lookup[]Junio C Hamano, Sep 10, 2020
  41. brian m. carlsonSep 10, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.